ExplorerHAT Pro blue LED not working


#1

Hello, I could use some help solving this issue.

Problem
Blue LED does not work, while the red, yellow, and green LEDs work as expected. Most of the time the blue LED just doesn’t work at all when calling explorerhat.light.on(). Occasionally it will dimly turn on just once but then subsequent explorer.light.on() will not turn on. Also, when calling explorerhat.light.pulse() I can see that it intermittently flickers but at a very low level.

Setup
RaspberryPi 3 Model B v1.2
Wall adaptor power supply (stock from Adafruit)

(ENV) pi@raspberrypi:~/Software $ pip show explorerhat
Name: ExplorerHAT
Version: 0.4.2

(ENV) pi@raspberrypi:~/Software $ pip show RPi.GPIO
Name: RPi.GPIO
Version: 0.6.3

(ENV) pi@raspberrypi:~/Software $ less /etc/modules

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

i2c-dev

Tried these from the forum without success:

Out of ideas, any thoughts?
I don’t think it is a HW issues (e.g. bad soldering) since there is some blue light activity. I have no other processes or jobs running. I am simply using python on the command line to import explorerhat and make the API calls.

Thanks in advance!


#2

Have you tried checking and disabling the 1-wire interface on your Pi with raspi-config or the Raspberry Pi Configuration tool? It uses BCM4 by default and is by far the most common cause of this kind of weirdness.