Explorer HAT Pro lights flicker constantly after second s/w install


#1

All was well with my Explorer HAT Pro and my code but I noticed I had not kept the Explorer’s software up to date. After updating the Explorer’s s/w the red, green and yellow lights constantly flicker whenever any script is run, even if that script is not manipulating the lights. It’s as if the lights are being put into an indeterminate state and left there.

To “upgrade” I followed the instructions at: https://github.com/pimoroni/explorer-hat to install. I ran:
curl get.pimoroni.com/explorerhat | bash and said Yes to all questions.
In hindsight this was probably a mistake as I could have just run pip with --upgrade. But this didn’t occur.

I have then verified I have the latest EH installed with:

pi@raspzumo ~/zumo $ sudo pip install --upgrade explorerhat
Requirement already up-to-date: explorerhat in /usr/local/lib/python2.7/dist-packages
Requirement already up-to-date: rpi.gpio>=0.5.10 in /usr/local/lib/python2.7/dist-packages (from explorerhat)
Requirement already up-to-date: cap1xxx in /usr/local/lib/python2.7/dist-packages (from explorerhat)
Cleaning up…

To give you an idea of the kind of script that will cause the R,G,Y (but not blue) flicker problem:

import explorerhat as eh
import time
eh.light.off()
time.sleep(5)

As you can see, the lights are told to be off yet they flicker.

Reducing this to just:

import explorerhat as eh
import time
time.sleep(5)

also causes the R,G,Y flicker.

I then tried:
sudo pip uninstall explorerhat
sudo pip install explorerhat
figuring that fresh code may be good. No dice: the flicker remains.

The last install did give one warning in case it is relevant:

Running setup.py install for explorerhat

warning: no files found matching 'captouch.py'

I’ve also checked and rpi.gpio is up to date at 0.5.10.

Any thoughts would be appreciated… my poor little robot is needed for a demo at the weekend.


#2

Fixed it…:

sudo reboot

sigh

I’m assuming that until the reboot the latest modules installed during the upgrade couldn’t be fully used and hence it all got a bit confused.

Pimoroni folks, please can you add a sudo reboot to the installation instructions, thanks.


#3

You had such detailed steps to reproduction and were so thorough and descriptive I was practically looking forward to sinking my teeth into this I wish all issues were reported this thoroughly, bravo!

Oh and… yeah we’ll see about adding a “You probably want to reboot now” step.

Thank you!


ExplorerHAT Pro blue LED not working
#4

That moment of “d’oh!” when I realised the solution is essentially to turn it off and on again ;)


#5

technically it seems like an odd glitch, I don’t think there is anything that would call for a reboot, as long as i2c didn’t need enabling as part of the process (which already flags a reboot message on screen).

if this proves a problem for others though, it’s easy enough to enforce a reboot regardless, it’s just a matter of turning a flag in the current scrip in fact, but I’m not a fan of forcing reboots just because I don’t know any better.