Did I mess up my Black Hat Hack3r?


#1

Hey guys, I got the Black Hat Hack3r and didn’t realise it needed assembly so naturally I went and bought a soldering iron and went to work. It wasn’t a perfect job I’ll admit but I feel the iron was too hot (no temp control tho) and may have messed up my board.

Here’s a picture:

As you can see it looks very… melty. I connected a simple resistor and LED to a breadboard and connected up the wires to ground and 5v. It lit up as normal, then I tried connecting to a GPIO pin and was going to set up a blinking test - but as soon as I connected it to the GPIO pin the LED lit.

So am I fucked?


#2

That soldering doesn’t look too bad to me - the flux in the solder melts onto the board which is why it has that shiny look to it. I doubt you’d have managed to lift any of the pads on the board, or damage it to the extent that the LED lit immediately on connection to a GPIO.

Try the LED on a different pin, and if you can post pics of all of the solder joints so any errors can be spotted.


#3

Thanks for the reply, here’s another picture, hopefully it’s clear enough

I tried the LED in another pin and it didn’t turn on like it did last time but it also did not turn on when programmed to.


#4

How did you wire up/program the LED