Automation HAT Mini on pi zero

Good evening.

What is the correct procedure to install an automation hat mini on a raspberry pi zero with raspbian light ?

The procedure suggested on the site installs a working system for the automation hat and for the phat.
The system is not working for the mini however.

Also, the examples are not fully copied (hat-mini lacks).

Any help greatly appreciated !


What is not working? What happens when you run the installer?
curl | bash
Do you get error messages etc?

Are these the examples your running?

The installation runs ok.

The examples from hat-mini are however not installed by the installation procedure.
When I copy the examples from hat-mini, when executed, no module ST7735 is found.

The older examples (hat) run flawlessly on the mini (as if it were a phat).

I will ty another install tomorrow with a full Rasbian on a pi 3B, and see what it gives.

Any other suggestions ?


I had a feeling that was going to be what you’d say.
ST7735 is I believe the LCD display. This one I think?

The installer for that is
curl | bash

Good morning !

Thank you for your response.

Actually, I did take these steps (for st7735) yesterday even before your reaction came.
But then other things came up.

When I run in the hat-mini folder, I now get this error message:

This Automation HAT Mini example toggles and displays the
status of the three 24V-tolerant digital outputs.

Press CTRL+C to exit.

Traceback (most recent call last):
File “./”, line 52, in
File “/usr/local/lib/python3.7/dist-packages/ST7735/”, line 156, in init
self._spi = spidev.SpiDev(port, cs)
FileNotFoundError: [Errno 2] No such file or directory

One step further ?


Problem solved !

I browsed the ST7735 init.pi file.
the spi-interface was not activated.

Thanks for helping me out.

Have a nice weekend.
And remain careful, stay safe and healthy.


My forum e-mails for what ever reason are going into my Outlook Spam folder. Which is kind of messing things up for me reply wise.

I had a similar issue with the 1.3 inch SPI one. SPI wasn’t enabled, at least that’s what I think happened. Anyway enjoy your new toy. =)