Blinkt Software

Hi, I have correctly attached a blinkt! to my RPi 3B+. Following the link from the product page via GitHub I tried the command “sudo apt-get install pimoroni” . This gave me the Pimoroni Dasboard. Then I tried “curl | bash” I then tried “sudo apt-get install python3-blinkt” I still can’t find the Examples. The folder in the Pimoroni Dasboard is empty and I can’t get anything from my Blinkt!. Please help. I am a beginner so need step by step instruction no detail too small. Thaks in advance.

curl | bash should install everything including the examples. They will be in Pimoroni > Blinkt > examples. I think thats the path. Look for a Pimoroni folder.

Hi I tried that but unfortunately my blinkt folder was empty.

Are you running Buster and do you get a weird error massage when you run sudo apt-get update?
If yes run sudo apt get update instead, then answer yes when prompted. Then run the one line installer again.

I have just tried again(3rd attempt) and this time it has worked. I don’t know what if anything I did differently but it has got the folders.Thanks for your help.

I did an update and wonder if my raspian upgraded to buster. I wonder if that has caused my issue. I had read that there are some issues with buster from raspian as it was waiting for a full release from debian. I have run windows for years and find it a bit hard to remember all of the commands. Fortunately I am old enough to remember DOS so terminal isn’t totally alien. Once again thanks.

I’m far from being any kind of expert on this but I “don’t think” just doing an update upgrade will upgrade you to buster. You have to do a dist-upgrade or something? There is a command you can run from terminal to see what your running. I’d have to google it to find out what it is lol.
If the internet and or your wifi connection gets glitchy things like this can happen.

I just got my first Pi 4B yesterday and got a weird error when I tried to run apt-get update. I had to Google it for the solution. What I posted above. New Buster images are up as of 07-10 which I assume fix that error.