Pantilthat Set-up Grief

Hi, Just purchased a PanTiltHat from you and trying to set it up with a new RasPi 3 B+ following the how-to instructions on your website.

Started with the recommended curl … | bash command which then ran so far but terminated with error messages about apt indexes.

Then tried to install the Pimoroni Dashboard. This seemed to go well and appeared in the Accessories list. Clicking on it just gives a brief screen flash of a possible dialogue then nothing (just desktop).

As this is a new RasPi it was set up with the supplied NOOBS card which installed the latest Raspbian Buster OS.

Any ideas

This is an issue because buster moved to stable after this release on the SD card. If you run sudo apt update and answer yes to the prompts then re-run the curl command once the update finishes everything should be OK.

Gordon

Try this, run sudo apt get update that should get you a yes no prompt. answer y and it should now update. From then on you can go back to running sudo apt-get update, upgrade
Then run the one line installer again.

EDIT Gordon beat me too it.

Thanks folks! Will give that a try very soon. 🤓

There is a new buster image up as of 07-10. Using that image likely fixes the testing to stable error message.

Thanks again. The advice given earlier worked fine and the Pantilthat is now up and running!

Now for some Python…