Bme680 smbus


#1

Having trouble using my BME680 after a manual install. When I run the read-all script as posted on the GitHub page I get the message:

File "/usr/local/lib/python3.7/site-packages/bme680/__init__.py", line 22, in __init__
    import smbus
ModuleNotFoundError: No module named 'smbus'

I’ve tried pip, pip3 and apt installing smbus but nothing is working to enable smbus. What can I do to get past this?


#2

Try the full, one line installer.
curl https://get.pimoroni.com/bme680 | bash
Its what I used with my BME680. I’m pretty sure I’ve run that example at least once with no issues. I’ll try it again latter on today if I get a chance on one of my BME680’s. Both are in service in running setups at the moment. Weather clocks.
Running the latest Raspbian?


#3

Thanks, I’m sure that will work, The full install worked for me last time I did it. I just want to do a manual install, and understand why this module isn’t being accessed correctly and what I can do to fix it.

Yes, it is the latest Raspbian-Lite and the latest Python 3.7.1


#4

Ok fair enough. My Linux skills are very basic so you’ll need somebody in the know to help you with that. You’ve already tried what I would have tried pip etc.


#5

Thanks, if no one else has a fix, I guess I’ll try burning another chip and not upgrading Python3 to see if SMBUS works that way.


Scrollphathd not working