BTN SHIM reports I/O error


#1

I can’t get any of the Button SHIM examples to work. I get this error:

Traceback (most recent call last):
File “keyboard.py”, line 4, in
import buttonshim
File “/usr/local/lib/python2.7/dist-packages/buttonshim/init.py”, line 379, in
_init()
File “/usr/local/lib/python2.7/dist-packages/buttonshim/init.py”, line 182, in _init
_bus.write_byte_data(ADDR, REG_CONFIG, 0b00011111)
IOError: [Errno 121] Remote I/O error

I’ve tried two different Raspberry Pis (a Pi Zero W and a Pi 3 now). I’m planning to use it together with the Unicorn HAT. The Unicorn HAT is working fine. I have also tried removing it but the button SHIM still doesn’t work.

Any pointers appreciated, thank you!


#2

Just to update that I have now tried using a clean SD card with the latest OS build on it, and the Button SHIM software as the only added software, and I’m seeing the same result.


#3

I’m guessing your running it in python 2, try running it in idle3/python3. It may have nothing to do with your error but can’t hurt to try it.


#4

Thanks for your help, alphanumeric. I have just fixed this. It was a soldering issue.

Sean


#5

Good to hear you got it working.