Can't find I2C devices on pico lipo on stemma port

I’ve put a pico lipo together with sparkfun and adafruit boards (STT522H and SHT41 respectively, sorry, spreading the love!) daisychained with stemma connectors.
pico lipo is running the picolipo micropython (Releases · pimoroni/pimoroni-pico · GitHub) and responds nicely.
I’m using machine.i2c with SDA 4, SCL5 as indicated on pinout and several step throughs including Adafruit AHT topic on this forum to check syntax etc but…
…no I2C devices found.
Any suggestions please?

Give this code a try and post back if it finds anything.
I just ran it on my Pico Lipo and it picked up what was on the Enviro+ I have it plugged into. I don’t have anything plugged into the Qwicc at the moment.

import machine
sda=machine.Pin(4) # Explorer 20 Breakout 4
scl=machine.Pin(5) # Explorer 21 Breakout 5
i2c=machine.I2C(0,sda=sda, scl=scl, freq=400000)
print('Scan i2c bus...')
devices = i2c.scan()
if len(devices) == 0:
  print("No i2c device !")
  print('i2c devices found:',len(devices))
  for device in devices:  
    print("Decimal address: ",device," | Hex address: ",hex(device))

thanks for picking this up. I’d tried this, and indeed trying again gives same result.
I think I’ll put another I2C device on a soldered connection, in case the qwiic isn’t as qwiic as hoped.
may not find time before end tomorrow … but I will update.

Just plugged a breakout into the QWICC on my Pico Lipo and it was also detected.
I’d say you may have a wiring issue? Double check that you don’t have SDA and SCL wired up backwards.

OK. back on it.
I’ve checked the pins are correcty connected with a DVM; I also setup another device on GP16/17 (this one hasn’t a QWIIC connector), pinned it through, and corrected the code to look for SDA/SCL on that area. I’m going to start from scratch again with a new .firmware; I also have a plain pico W which I’ll try now i’ve got the solder out.

OK. now the soldering iron is out and the pins are in, I’ve got SDA 4,5 working and finding at least one of the devices.

Which rather annoyingly leaves the ‘easy, just plug in’ qwiic connectors at fault.
Consider me back on the rails, though, I’m now comfortable I wasn’t missing anything stupid (connectors aside). I seem to have a picoLipo that won’t use the qwiic connection…
thank you for your attention.

set up an I2C display on GIO 17, 18 and found that .

sorry, ignore the last
I’ve now learned what I think i read somewhere, which is that qwiic cables are crossover - and the ones i\ had made up are not. they’re all getting re-aligned now.

The qwicc cables I have are wired identical at each end. The pin layout and wiring is identical, there is no crossover of the wires.
SDA - Yellow
SCL - Green
3.3V - Red
GND - Black
Something else that can mess you up is the i2c pullup resistors. The Pico Lipo has them on GP 4 and 5. Switch to other pins and you need to add your own 10k pullups.