DFRobot 2.8 USB TFT Pi 2 Raspbian Setup Guide ( Advanced )


awww. gadgetoid, thanks a lot. Yes, I am waiting patiently.

Thanks :)


Instructions are here: https://github.com/pimoroni/rp_usbdisplay

Make sure your Pi is up to date, as instructed, clone the repo and run “install.sh

You can then continue with installing the 10-robopeak.conf file as instructed in the second post of this thread.


Thanks! I will use this. :)

The steps mentioned as “Manually” are alternative steps, right?


Yes- they’re alternative. The script does the same thing for you.

I need to update the script to add the module name into /etc/modules or perhaps create a device tree blob if that can accomplish the same thing- at the moment I don’t think it loads on reboot and you may have to: modprobe rp_usbdisplay again


muito obrigado, excelente trabalho.


Hi, I have a question. Anyone please suggest.
Even after update and upgrade if a raspberry pi B+ says “Sorry the current kernel not supported”. does it mean this display won’t work with 4.1.7+?



I added 4.1.7+ support a few weeks ago and made some changes to the installer to better support new kernels when they crop up.

You will either need to git pull if you used git to clone the repo, or re-download it from GitHub to get the latest files.



Do you know I can see both the HDMI and the USB display at the same time! I can even see the camera preview at the same time!

I did,

  1. Manually setup the display for my pi 2 using the github 4.1.7+ drivers.

  2. Then I did the 10.robopeak.conf file. But after doing framebuffer copy I removed the file.

  3. I did the tasanakorn fbcp run.

I saw I can see both displays at the same time! Never saw this before.

Sorry if its something already done by you all. I am excited. And so I thought I should share. :D

Now I want to do this for another older version of pi. Keeping my fingers crossed! 😀


i get a lot of input lag and frame rate issues with retro pie


so i reinstalled everything and the scrolling text appears but then a cursor blinking appears and not the gui


Framerate may always be an issue out of the box, for two reasons:

  1. GPU acceleration isn’t supported over anything but HDMI as far as I’m aware
  2. By default the frame-rate is limited to 16fps in the kernel module, I think there’s a way to change this, which might be:

(with another display connected)

sudo rmmod rp_usbdisplay
modprobe rp_usbdisplay fps=30

You can then add the fps switch the appropriate conf file: /etc/modprobe.d/*.conf

I’m not familiar with the blinking-cursor-no-GUI issue. But I would suspect a configuration error somewhere along the journey! I don’t have any gear to hand to try out any hypothesis right now, though :(


So i tried using the installer on my raspberry pi zero and it initially says it detects the usb display but when it goes to test it it says the module cant be detected.


D’oh! What do you see if you run:

uname -a


cat /etc/os-release


Had some time and thought I’d give getting this display up and running another shot.
Beautiful installer :-)

Shame I keep my RPis constantly updated because it looks like you’ve updated it for the October 2016 release… "Sorry. Current running kernel is not supported."
Linux raspberrypi 4.4.38-v7+ #938 SMP Thu Dec 15 15:22:21 GMT 2016 armv7l GNU/Linux
(RPi3, if it matters…)


Yeah I’ve been struggling to keep ahead of all the releases, on top of everything else. This damned driver needs tidying up and upstreaming, but DFRobot haven’t made that easy.

I’ve been meaning to push the latest kernel versions for a while! It’s not all that difficult to build, actually, mostly just unpicking their messy sourcecode and moving a few things so it’ll compile. I have a VM setup for this :D


I’ve added support for 4.4.38-v7+. A/B/Zero module to follow.



ive installed the software from the github page but both my pi3 and pi zero W wont work with the display.The display gives a constant ‘waiting for signal’ static screen. ive tried rebooting and reinstalling


What output did you see during the install process?


i set the github process going, both Pi terminals say they cant detect the screen and ask if its plugged in, which it is. so I hit the Y key and let it run through the install process. the screen never itself changes from the static screen after running through the boot up process.


Hey, did you install the 10-robopeak.conf?