DFRobot 2.8 USB TFT Pi 2 Raspbian Setup Guide ( Advanced )


#62

In this directory /usr/share/X11/xorg.conf.d/


#63

Just checked, Ive got no such directory so I must not have. is that on the github page?


#64

Yeah it is, and trust me you should have it but it took a while for me to find it. Hang on let me see if I can show you.


#65

I’ve managed to locate it now. when I try moving the 10-robopeak.conf file I get permission denied.


#66

Enter this as a command in the terminal

sudo chmod a+w /usr/share/X11/xorg.conf.d/

This article can help you in the future, it offers a really useful key that is simple to follow I hope


#67

Great! Thank you so much!


#68

My pleasure pal, DM me if you need anything else


#69

One more thing, if you ever want to stop using the usb display and connect to another monitor, try taking that txt file out of the directory and saving it to desktop to keep it safe. Then just put it back when you wanna use the screen.

I couldn’t find another way otherwise


#70

Nice one, I also added the xdisplay thing to the boot so it starts automatically, now the pi boots with the resolution of the USB screen but the monitor still displays the same static screen with the message waiting for signal. Im remoted in using VNC so I can see what’s happening


#71

I’ll tinker some more tomorrow and report back


#72

@dudeitsjackwild could you screenshot or copy and paste the output from the installer? And/or paste the output of uname -a


#73

@gadgetoid just reinstalled my Raspbian image, went through the installation process again and all worked great. managed to get the screen up and running now. must of been a user error. Thanks for the help anyway


#74

Great news. My bet is that it was a pre-release kernel version installed by rpi-update, or perhaps an out-of-date kernel that I missed support for. Nevermind!


#75

When i add kernel=kernel17-rpusb.img to nano /boot/config.txt it said permission denied any help?


#76

What’s kernel17-rpusb.img!?


#77

there highlighted in bold


#78

Oh, good grief, I should probably delete those instructions now! They’re so woefully out of date as to be worthless. See:


#79

Hi
Is there a way to get this display working on a Pi3?
I’m new to Pi and just bought a 3 for a specific project using this screen and didn’t notice that it doesn’t list Pi3 as being supported. When I try to Install I’m told my kernel is not supported (4.9.35-v7+ #1024).
The installer then directed me to the dkms page, which I tried to follow but the second command there (sudo dpkg -i rp-usbdisplay-dkms_1.0_all.deb) gave 'cannot access archive: no such file or directory.

Any help? Please be gentle as I’m new to Pi and generally use Windows 10.

Thanks


#80

If you cloned down the GitHub repo, you’ll need to cd (Change Directory) into the dkms directory before running the dpkg -i command. You’re on the right tracks, though, the dkms package should get you up and running on a Pi 3.


#81

I knew it would be something as simple as that.
It’s working now, thanks