Unable to get Display-o-Tron installed


#1

Hi, I am very new to Raspberry Pi and have just tried to install the Display-a-Tron3000 with no real success. I have tried the upgrade route as described above but only got the following:-
pi@raspberrypi ~ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done The following packages have been kept back: lxpanel lxpanel-data minecraft-pi raspberrypi-ui-mods 0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded. pi@raspberrypi ~

I would really appreciate some assistance. Thank you.


Raspberry Pi 2- What works and what doesn't!
#2

What problems are you having with Display-o-Tron, it sounds like you’re up-to-date apart from the new UI stuff which you can get with a dist-upgrade ( I found it easier just to re-download Raspbian and copy it onto your SD card than do a dist-upgrade, but I had some pretty ancient Pi setups ).

What’s not working? Does the install script complete:?

curl get.pimoroni.com/dot3k | bash

#3

Thank you. In truth my daughter and I were totally stumped. We have been unable to find an idiots’ guide for Pi Newbies at all so will go and try your piece of code shortly.


#4

I have input the above code and the DoT3k is still not functioning. Any other ideas please?


#5

Can you elaborate on what you mean by “not functioning”.

What are you trying, and what output/error messages are you getting ( if any )?

If you can get a couple of screenshots/photos of what you’re attempting on the Pi, it would be tremendously helpful.


#6

Hi Again,
Okay since yesterday my daughter and I were able to get the DOT3K to light up and display the screen saying “Have fun!” and we were delighted. BUT, and I bet you heard that coming. We were following your tutorial and could find the Pimoroni files but executing them, opening them and copying and pasting the code into a) the terminal screen or b) the Python2 shell all produced zip, nothing, nada. We rebooted. We updated using the apt get (as far as memory serves - but copied from your site) to make sure Rasbian was up to the moment.
Please advise as to where we are going wrong - bearing in mind this is a whole new world for us.
Thank you for your assistance.