Display-O-Tron 3000 not working (no light, no text)


#1

I´m trying to use the Display-O-Tron on a Raspberry Pi 3 Model B. The main purpose of this Pi is running as an emulation station for my kid. Retropie and 10,000 games plus Kodi and Kodi extensions have been installed so I really don´t want to have to start from a blank SD card just to use the Display-o-Tron. I have updated to the latest version of Raspbian and did the one line install. I got the message in the terminal that everything was completed ¨Enjoy your Display-o-Tron 3000/HAT!¨. The display did not light up. Rebooted, same result. Updated again and installed the displayotron software again. Same result.

I entered cd ~/Pimoroni/displayotron/examples-backup, then sudo ./joystick.py and got the message command not found.

from dot3k import lcd
Gives the message ¨can´t read /var/mail/dot3k¨

from dot3k import backlight
Gives the same message

I´m wondering if the unit might be DOA


#2

it is almost certainly a software issue… though I have no idea what that message means, it is quite unusual and does not make much sense.

You should try first on a clean SD to completely rule out a hardware fault. By this I am merely suggesting you confirm the DoT 3K works in a controlled environment, not that you should start from scratch on your setup.


#3

Thanks for the reply. I tried again with a newly formatted SD card. Installed NOOBS and updated to the latest version. Then installed the dot3k software and am encountering the same issues. I’m totally new to python so I’m kind of at a loss and there doesn’t seem to be anyone else with this particular issue so troubleshooting has been a pain.


#4

How are you trying to run your Python script?

It just occurred to me that from is a valid command in bash- running /usr/bin/from

You should be running your Python scripts with Python, like so:

python myscriptfile.py

#5

I’m just following the instructions on this page from A-Z https://learn.pimoroni.com/tutorial/display-o-tron/getting-started-with-display-o-tron.

I’m entering the script just as its shown here


#6

you cannot simpy type this at the console, you have to be in the python interpreter - or save to a file and execute. see this introduction:


#7

Well I feel dumb. I’ll read through that. Even still, the screen should at least turn on after following the instructions on the “getting started with DoT” page, correct? Brand new SD card, new install and update to latest version of Raspbian, installed DoT 3K software.


#8

well, it’s possible the contrast is not sufficient to read the text. Try:

lcd.set_contrast(contrast)

the backlit should work though, right?


#9

There is no backlight at all. The software says everything is ready after install, but the DoT doesn’t light up.