Display-O-Tron HAT and RaspberryPi2 no text


#1

Hello Everyone,

I just set up my Display-O-Tron HAT with our Raspberry Pi 2 and just like mentioned in older threads about the Display-O-Tron 3000, I have the problem that I don’t see any text on the display.

Background- LEDs, Bargraph-LEDs and the touch controls seem to be working just fine.
I Updated the Raspbian Installation and issued your script

\curl -sS get.pimoroni.com/dot3k | bash

several times, but it doesn’t seem to set things up correctly.
I ran all the examples from /Pimoroni/dot3k/dothat/basic and advanced but none of them showed any text.

I’d love to have some output on my screen, the colors are already amazing ;)

What can I do, to help you track down my problem ?

Best regards, Christian


#2

OK its working now! I did two things, don’t know which one did the trick, you guys have to decide that ;)

1) I installed the Wiring Pi code (because I thought it might be needed)

cd /tmp
git clone git://git.drogon.net/wiringPi
cd wiringPi
./build 

2) Edit /boot/config.txt
I changed

device_tree=

to

# device_tree=

so it looks like setting device tree off by setting it to “nothing” does not work (what happens when you disable device tree in raspi-config).

It seems like one of these changes finally fixed my problem. And I’m now very happy with my new Display-o-tron Hat.


#3

I’m glad you got your problem fixed. I’d love to get to the bottom of it for future reference, though.

I’m not sure if it’s supported on the Pi’s version of pip, but could you possibly run the commands:

pip show st7036
pip show dot3k

And let me know what versions of each library you’ve got. Thanks!

I made a fix to the Dot3k/DotHAT library recently which properly sets up the reset pin so the LCD isn’t held in permanent reset. It’s possible you got around this by enabling device tree, in which case your Pi will read the HAT EEPROM and set the reset pin to a sensible default. I’m speculating, though!


#4

Hi @gadgetoid!

As you already mentioned, since pip show is only available in >= 1.3 I don’ t have it installed since I’m using a “vanilla” Raspbian on a RaspberryPi 2!

I can only use the “freeze | grep” way in pip v1.1 which gives me:

pip freeze | grep st7036
st7036==1.4.0

pip freeze | grep dot3k
dot3k==2.0.1

I will later switch to an Arch-Image but couldn’t at the moment, due to the the outage of lm-sensors.org! All the stuff needed for your display to work gets pulled directly from upstream when using yaourt to install packages from the AUR! It would be great if you maybe could mirror the necessary packages from lm-sensor.org under your github account? Distribution-wise that could be a blast as I’m currently experiencing with my ALARM Pis!
Not that I don’t like Raspbian, I love debian… but at home I’m using an Arch on my desktop and Pis on arch seem to be my perfect fit !

Let me know if I can be of any more help!

Best regards,
Christian