Displayotron HAT not working on RPi3


#1

Hey there,

I have been trying without success to get my Displayotron to show anything :(

I am running a RPi3 with “Raspbian GNU/Linux 9 (Stretch)”

After having performed a sudo apt-get update and upgrade, following the instructions here: https://learn.pimoroni.com/tutorial/display-o-tron/getting-started-with-display-o-tron, seems to be causing me issues.

The script runs from, however it advises that it is unable to install smbus, that support for this OS is experimental.

I have tried running the basic python scripts. The hello_world.py one runs with a message stating in the terminal that “Hello world” should be displaying, and then saying to hit Ctrl+C to exit, but just terminates anyway.

The backlight.py script produces a 121 : Remote I/O Error.

Can somebody point me in the right direction with this? The Displayotron would be a cool piece of kit if I can get it working :D

Shaun Connelly-Flynn


#2

Stretch or Jessie? I’m guessing Stretch, if so you may want to start over with Jessie.


#3

I am on Stretch – where can I get Jessie from? Have been looking but unable to find a download for it.


#4

They should make that easier to find on their web site?
I found this though, http://downloads.raspberrypi.org/raspbian/images/


#5

Thank you! I am now reimaging my card.

On a semi-related note, the SD card I was sold with my RPi3 was a dud – it bricked after about 6 uses over three months!! Was trying to install the DisplayOTron HAT at the same time when it all went awry, and have not been able to find the Jessie images, so I hope this should do it for me. Will let you know how it goes.

Thanks again for pointing me in the direction of the images.


#6

2017-07-05-raspiian-jessie is the last one I saved before they switched the downloads page to Stretch. I always keep the previous release for a while just in case I need to go back a version. I’m only running Stretch on one Pi at the moment. All my other Pi’s are running headless and there is no advantage to updating them. They are working fine and doing what I set them up to do. Eventually sites like Pimoroni will catch up to the changes made to Stretch and fix their tutorials etc to work with it. Sometimes even subtle changes break things.


#7

I’ve had one SD card die on me. It saw a lot of use and was reimaged several times. Just bad luck I think. I have others by the same manufacturer bought at the same time with similar use still working fine.


#8

I tried it, and still have the same issue. When I run a couple of the scripts, this is what I am getting:

`pi@raspberrypi:~/Pimoroni/displayotron/examples/dot3k/basic $ python hello_world.py

This example shows a basic "Hello World" on the LCD.
You should see "Hello World" displayed on your LCD!

Press CTRL+C to exit.

pi@raspberrypi:~/Pimoroni/displayotron/examples/dot3k/basic $ python backlight.py
Traceback (most recent call last):
  File "backlight.py", line 5, in <module>
    import dot3k.backlight as backlight
  File "/usr/local/lib/python2.7/dist-packages/dot3k/backlight.py", line 1, in <module>
    import sn3218, colorsys, math
  File "/usr/lib/python2.7/dist-packages/sn3218.py", line 114, in <module>
    enable_leds(0b111111111111111111)
  File "/usr/lib/python2.7/dist-packages/sn3218.py", line 62, in enable_leds
    [enable_mask & 0x3F, (enable_mask >> 6) & 0x3F, (enable_mask >> 12) & 0X3F])
IOError: [Errno 121] Remote I/O error
pi@raspberrypi:~/Pimoroni/displayotron/examples/dot3k/basic $`

This is following a sudo apt-get update and sudo-apt install. This time though, the script from get.pimoroni,com/displayotron ran with no errors showing. :(

The hello_world.py script says it ran, but nothing happens on the Displayotron, and the backlight.py script just shows a series of error messages.

Help!


#9

I won’t be of much more help unfortunately. I don’t have a displayatron, I wish, but no.
Did you Google “IOError: [Errno 121] Remote I/O error” to see what turns up. I have some python skills but I’m far from being an expert. I don’t know what that error means.


#10

Using the dothat module instead of dot3k showed the text properly for me, even that I use the Breakout version and not the HAT. I am still getting the same 121 Error as you are, though.

Edit: dothat.backlight still does not work for me, but the example scripts in the tutorial that use PWM to drive the backlight are working for me now.