DOTHat flop


#1

Any ideas gratefully received. Running latest raspbian updates, with cayenne in the background.

Have done a couple of fresh installs since last used DoTHAT last but dusting it off for a new project.

Using the curl script listed on the DOT’s Git, I get the following:

(Successful python2 dep installs above here)

Successfully installed dot3k st7036 sn3218 cap1xxx spidev
Cleaning up…
Done!

Checking for Python 3 library…
Traceback (most recent call last):
File “/usr/bin/pip3”, line 9, in
load_entry_point(‘pip==1.5.6’, ‘console_scripts’, ‘pip3’)()
File “/usr/lib/python3/dist-packages/pkg_resources.py”, line 356, in
load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/usr/lib/python3/dist-packages/pkg_resources.py”, line 2476,
in load_entry_point
return ep.load()
File “/usr/lib/python3/dist-packages/pkg_resources.py”, line 2190, in load
[‘name’])
File “/usr/lib/python3/dist-packages/pip/init.py”, line 74, in
from pip.vcs import git, mercurial, subversion, bazaar # noqa
File “/usr/lib/python3/dist-packages/pip/vcs/mercurial.py”, line 9,
in
from pip.download import path_to_url
File “/usr/lib/python3/dist-packages/pip/download.py”, line 25, in
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead’
Installing Display-o-Tron 3000/HAT library for Python 3…

Traceback (most recent call last):
File “/usr/bin/pip3”, line 9, in
load_entry_point(‘pip==1.5.6’, ‘console_scripts’, ‘pip3’)()
File “/usr/lib/python3/dist-packages/pkg_resources.py”, line 356, in
load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/usr/lib/python3/dist-packages/pkg_resources.py”, line 2476,
in load_entry_point
return ep.load()
File “/usr/lib/python3/dist-packages/pkg_resources.py”, line 2190, in load
[‘name’])
File “/usr/lib/python3/dist-packages/pip/init.py”, line 74, in
from pip.vcs import git, mercurial, subversion, bazaar # noqa
File “/usr/lib/python3/dist-packages/pip/vcs/mercurial.py”, line 9,
in
from pip.download import path_to_url
File “/usr/lib/python3/dist-packages/pip/download.py”, line 25, in
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead’
Python 3 library install failed!

Suggestions on a scenic postcard?


#2

not happening here, so I suspect it was a temporary glitch? either way you should still be able to use python 2 until the dust settles, or does the script abort?