Enviro+ display not working in Python3

Fresh install of the library and dependancies for the Enviro+ hat on RPi
Everything else works out of the box (so far) but the LCD won’t work if I run it in python 3. The error is as follows:

pi@rpi:~/enviroplus-python/examples $ python3 lcd.py
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/dist-packages/numpy/core/__init__.py", line 22, in <module>
    from . import multiarray
  File "/usr/local/lib/python3.7/dist-packages/numpy/core/multiarray.py", line 12, in <module>
    from . import overrides
  File "/usr/local/lib/python3.7/dist-packages/numpy/core/overrides.py", line 7, in <module>
    from numpy.core._multiarray_umath import (
ImportError: libf77blas.so.3: cannot open shared object file: No such file or directory

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "lcd.py", line 3, in <module>
    import ST7735
  File "/usr/local/lib/python3.7/dist-packages/ST7735-0.0.4-py3.7.egg/ST7735/__init__.py", line 23, in <module>
    import numpy as np
  File "/usr/local/lib/python3.7/dist-packages/numpy/__init__.py", line 140, in <module>
    from . import core
  File "/usr/local/lib/python3.7/dist-packages/numpy/core/__init__.py", line 48, in <module>
    raise ImportError(msg)


Importing the numpy C-extensions failed. This error can happen for
many reasons, often due to issues with your setup or how NumPy was

We have compiled some common reasons and troubleshooting tips at:


Please note and check the following:

  * The Python version is: Python3.7 from "/usr/bin/python3"
  * The NumPy version is: "1.19.4"

and make sure that they are the versions you expect.
Please carefully study the documentation linked above for further help.

Original error was: libf77blas.so.3: cannot open shared object file: No such file or directory

The example runs fine in python2, but not python 3.x.

I installed via the single-line install as per the documentation and have rebooted. Any leads on getting numpy to play nice in py3?

Try the following and have another go.
sudo apt-get update
sudo pip install st7735
sudo pip3 install st7735
sudo apt-get install python-rpi.gpio python-spidev python-pip python-imaging python-numpy
sudo apt-get install python3-rpi.gpio python3-spidev python3-pip python3-imaging python3-numpy

Worked without errors, except one pointing out that python3-imaging has been replaced by python3-pil

The error persists though, but only in python3

Looks like a NumPy error, solved with

sudo apt-get install libatlas-base-dev

OK, glad you sorted it out. I have a bunch of those displays and run modified Enviro / Enviro+ code on them. I don’t own an Enviro or Enviro+ though. I haven’t started over from scratch in a while, over a year I think?