Enviro+ not responding

I have just started to configure Envro+/PI Zero/ PM2.5 Sensor assembly and hit a bit of a problem!
I am following the Getting Started with Enviro’ article and just tried to run the weather.py example.
‘No module named bme280’ is reported back and there there is nothing on the Enviro display.
Is it dead or have I missed an important step?

Just used my multimeter to check the voltages on the Enviro+ GPIO 5 and 3 Volt pads. They measured correctly so the boards are ‘joined’. There are no lights on the E’ board and its display is blank.
Could it be that the PI-Enviro data connection has not been turned on?

Did you install the python software?
curl -sSL https://get.pimoroni.com/enviroplus | bash
git clone https://github.com/pimoroni/enviroplus-python
cd enviroplus-python
sudo ./install.sh
And double check that i2c is enabled, and I think you also need spi enabled for the display to work.
sudo i2cdetect -y 1 should show the i2c address for the sensors

  • 0x49: ADS1015
  • 0x76: BME280
  • 0x23: LTR559

Thanks Kerry, that got it going.
I had certainly completed the git… line but running ./install.sh line again started everything, perhaps I’d missed it.
I have continued to work through the 'Getting started…" article but have come to a halt in the Python library section, from smbus2 import SMBus it cannot find smbus2
Odd as the all-in-one.py finds and displays all the sensors.

I’m going to guess your running Buster Lite, which may be missing smbus.
Try running this from the terminal Window
sudo apt-get install -y python2-smbus
or maybe
sudo apt-get install -y python-smbus

My ignorance is total, I don’t know what I am using!
I bought a pre-flashed SD with Noobs from Pimoroni and during setting up a long update and install process took place and it now boots to a Raspberry Desktop, I then use its Terminal app. What version/flavour it is, I have no idea and cannot find where it might say it. Sorry to be so dumb!
Should I determine if it is python or python2 before trying those lines?

If it’s booting to the Desktop its not the lite version. The Lite version boots to command line.
I’d try the first one I posted, the python2 one should be for smbus2. As far as I know you can run both with no ill effects, they don’t overwrite each other.

Thanks again Kerry. Unfortunately those install lines did not enable the smbus2 line to run. I checked on line and found sudo pip install smbus2 which did work and then the next calls of temp, pressure and humidity values all worked!
Moving on to the light and prox sensor then the gas sensor sections, the while statements did not return anything?

I’ll have to make note to run pip instead of what I posted in case this crops up again.
The weather.py file doesn’t do anything with the light or prox sensor. Near as I can tell anyway.
Try running light.py and or gas.py?

Hello. I too am having problems getting the enviro+ module to work on my pi zero. I had it working on a Raspberry 3, have followed the same install process. Have checked voltage on the board to be sure it’s working. If i run any of the example scripts i get this error

File “weather.py”, line 4, in
from bme280 import BME280
File “/usr/local/lib/python2.7/dist-packages/pimoroni_bme280-0.0.2-py2.7.egg/bme280/init.py”, line 2, in
from i2cdevice import Device, Register, BitField, _int_to_bytes
ImportError: No module named i2cdevice

Have checked with i2cdetect that ADS1015, BME280 and LTR559 shows on the correct part so am now stuck what to try next.

Any help greatly welcomed

One thing to watch out for is python 2 versus python 3.
What method are you using to run the examples?

the tutorial says to type
python luftdaten.py

not idea which version that uses.

python runs it in python 2, type python3 and it will (try to) run in python 3
try python3 luftdaten.py You might get lucky and have it run.

sigh, nope. still the same error

Another stab in the dark, you could try running the following
sudo pip install pimoroni-bme280
sudo pip3 install pimoroni-bme280