Enviro + not working

Hi all,
I haven’t been able to do make my raspberry pi enviro+ hat work.
i’ve run updates and downloaded the github directory as well as running the install command.
i’ve tried it on both a pi4 and a pi 2b but neither can run any of the sensor examples however they can run the lcd script and that works fine.
I’m a beginner to all this so any help would be massiviley helpful.
Thanks

Make sure i2c is enabled? Any error messages etc?

I’ve selected i2c to be enabled, the error messages i get are either bme280 not at 0x76 or a runtime error.
When i run i2cdetect 1 I just get – for each space.
Sorry if that isn’t helpful, thanks

When i run i2cdetect 1 I just get – for each space.

That means it can’t detect the sensors, which chimes with the “not at 0x76” error. If the screen is working perfectly and you can see the proper images on it then that’s a little strange (the screen uses a different communication bus, but that means the baord is definitely plugged in right).

Are you running the latest Pi OS? Do you have any other small breakouts or sensors you could try this with? If you look at the back of the board, are there any blank pads where components may have been knocked off?

I don’t think there’s anything knocked off and on the pi 4 I’m running NOOB and I’m not sure about the pi 2

Noobs isn’t an OS by the way. It’s a utility to help you install an OS. It does a bit more than that but that’s basically what it is. The Pimoroni software is written for Pi OS.

okay, I’ll try to install the proper pi os, when i run cat /etc/os-release i get this message
PRETTY_NAME=“Raspbian GNU/Linux 11 (bullseye)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“11”
VERSION_CODENAME=bullseye
ID=raspbian
ID_LIKE=debian
HOME_URL=“http://www.raspbian.org
SUPPORT_URL=“RaspbianForums - Raspbian

and this BUG_REPORT_URL=“RaspbianBugs - Raspbian