Enviro + air not working after installing code

I recently got the enviro + air quality, and Im having trouble getting it started. when i first installed the one line code, it aborted itself, so i updated rasbian. after, I installed the sensor board on the pi, the screen flashed and turned off, and I re ran the one line code. It installed, but the screen on the board is not showing any data or turning on. Even after restarting and re plugging in the board, i still see nothing. Im not sure what Im doing.

curl -sSL https://get.pimoroni.com/enviroplus | bash
Only installs the software to enable you to make use of it.
To actually use it you need to run some python code, did you try running any of the examples from here

to me this almost sounds like you plugged the screen into a running Pi. if so that’s a no no ,Pi must be off to plug any hat into it ,

thanks for that, i assumed the board worked like hyperpixel and would just start. I copied the code from the all-in-one-enviro-mini.py file, and when I run the code i see the back light of the display working, but nothing is displayed on the screen. The board is registering, as i can see the temperature readings in the IDE.

Make sure i2c and SPI are enabled in raspi-config.
PiOS Lite or PiOS with desktop?

its pios with desktop, and i2c and spi are enabled

Ok, I asked because the Lite edition can sometimes be missing a “needed” dependency that the with Desktop edition has by default.
Try running the following from terminal.

sudo apt-get update
sudo apt-get install python-rpi.gpio python-spidev python-pip python-imaging python-numpy
sudo apt-get install python3-rpi.gpio python3-spidev python3-pip python3-imaging python3-numpy

i did a full upgrade to the OS yesterday, so i ran the 2 other lines. even after a restart, nothing is running on the screen. the desktop version should have the fonts installed, yes? if not, where do I get them and how do i install them?

I have this in my crib notes for my Breakout Garden setup, I was running some of the Enviro+ examples on it, namely the all_in_one_mini.py
I have a BME280 and that 160x80 display setup in it.

From a terminal window run the following
sudo pip3 install fonts
sudo pip3 install font-roboto