Enviro Phat Install Fails


#1

Run curl -sS get.pimoroni.com/envirophat | bash
on a freshly installed Zero, get the following

Installing Enviro pHAT library for Python 2…

Downloading/unpacking envirophat
Cleaning up…
Exception:
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/pip/basecommand.py”, line 122, in main
status = self.run(options, args)
File “/usr/lib/python2.7/dist-packages/pip/commands/install.py”, line 290, in run
requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
File “/usr/lib/python2.7/dist-packages/pip/req.py”, line 1178, in prepare_files
url = finder.find_requirement(req_to_install, upgrade=self.upgrade)
File “/usr/lib/python2.7/dist-packages/pip/index.py”, line 194, in find_requirement
page = self._get_page(main_index_url, req)
File “/usr/lib/python2.7/dist-packages/pip/index.py”, line 568, in _get_page
session=self.session,
File “/usr/lib/python2.7/dist-packages/pip/index.py”, line 694, in get_page
req, link, “connection error: %s” % exc, url,
TypeError: str returned non-string (type Error)

Storing debug log for failure in /root/.pip/pip.log
Python 2 library install failed!
If problems persist, visit forums.pimoroni.com for support


#2

Wow that’s a verbose error output for a simple failure. Darn pip is useless :D

The key words here are, I think, “req, link, “connection error: %s” % exc, url,”

Looks like you, or the Python package index, might be having some intermittent connection errors. Give it another go!


#3

Will try again, actually tried a few times previously, all failed with the same, internet was working as far as idle same time browsing was OK. Other libraries get updated prior to this ok.


#4

Worked after trying again, also got something similar for MicroDot phat, so it seems if you get a spurious message like this, just keep trying to do the install.