Envirophat on bullseye?

Any advice on getting Envirophat playing nicely on Bullseye? I’ve been seeing these errors:

pi@raspberrypi:~/Pimoroni/envirophat/examples $ ./all.py
Traceback (most recent call last):
File “/home/pi/Pimoroni/envirophat/examples-backup/./all.py”, line 6, in
from envirophat import light, weather, motion, analog
File “/usr/lib/python3/dist-packages/envirophat/init.py”, line 1, in
from .i2c_bus import bus
File “/usr/lib/python3/dist-packages/envirophat/i2c_bus.py”, line 20, in
bus = smbus.SMBus(1)
FileNotFoundError: [Errno 2] No such file or directory

I am also using a waveshare relay board. They seem to play together nicely in earlier raspbian builds!

pi@raspberrypi:~/Pimoroni/envirophat/examples $ cat /etc/*release
PRETTY_NAME=“Raspbian GNU/Linux 11 (bullseye)”
NAME=“Raspbian GNU/Linux”
VERSION=“11 (bullseye)”
SUPPORT_URL=“RaspbianForums - Raspbian
BUG_REPORT_URL=“RaspbianBugs - Raspbian

That looks like a Python version issue. Bullseye doesn’t have python 2, it only has python 3. Try running
sudo python3 -m pip install enviroplus

I don’t have an Enviro but I am running modified Enviro examples on the equivalent Breakout garden setup. And not having any issues in Bullseye.

EDIT: looks like you edited your post while I was typing mine. Make sure i2c and SPI are enabled.

Thank you! python2 was throwing me. Trying now with python3 (on a clean install) since I have a couple other hats that might have installed conflicts

ok, user ahnlak on the discord spotted it for me. I had somehow disabled I2c. Turning it back on with raspi-config fixed my issue