Error with Scroll pHat installation


#1

Hi.

First of all I apologize for my English I defend myself with reading but little more, but I have a problem with the “Scroll pHat”

To date I have worked perfectly on a Raspberry Pi Zero 1.3, with OS Raspibian Jessie. Decided to upgrade to the latest version Raspibian Jessie with pixel starting at 0.

I previously did apt-get update and upgrade and enabled SPI and i2C but when I installed the drivers as indicated by “curl -s -s https://get.pimoroni.com/scrollphat | bash” I get this error: "Apt Failed to update indexes! "

I do not find a solution and my knowledge about this OS are few at the user level recently arrived from Windows so I do not know how to go forward, if they could help me I would be very grateful.

Bye.


#2

That’s curious. Might be a bug in our scripts, or perhaps a problem with your setup. I’ll summon @RogueM and see if he has any ideas.

Could you paste the full output of the error please? If the forum rejects it, try http://pastebin.com/


#3

Hello again.

Thanks for replying, this output the screen with the error.

pi@raspberrypi:~ $ curl -sS https://get.pimoroni.com/scrollphat | bash

This script will install everything needed to use
the Pimoroni Scroll pHAT

Always be careful when running scripts and commands
copied from the internet. Ensure they are from a
trusted source.

If you want to see what this script does before
running it, you should run:
\curl -sS https://get.pimoroni.com/scrollphat

Note: Scroll pHAT requires I2C communication

Do you wish to continue? [y/N] y

Checking environment…
Updating apt indexes…

Apt failed to update indexes! ->
pi@raspberrypi:~ $


#4

Did apt-get upgrade completed successfully? and was it completed when you launched the script?

I ask because the step failing is a very simple apt-get update, and you can’t have multiple processes operating over dpkg simultaneously.


#5

Yes, in fact and to make sure once the upgrade is finished, restart the raspberry pi zero


#6

Hello again.

I have tried to install the drivers for phat blink and microdot (I do not have them at the moment, but the microdot is my next purchase) and I get the same result “Apt failed to update indexes!”

I have tried to install other soft, like the Ninja-IDE, OLED displays (Adafruit), Python add-ons, and various utilities, both from the command line and from the graphical environment, and without any problem.


#7

are you sure that apt-get update works correctly for you. The most likely is that you have a dependency missing for a manually installed package and it is returning an exit code!


#8

The upgrade does not mark error, I tried a clean installation on a raspberry pi 3, and before and after upgrading gives the same error. I can only search for an older OS version and try


#9

hold on, I’m not talking about upgrade… can you post the full output of:

sudo apt-get update

#10

anyhow, you can try the following, which will bypass the syncing of indexes:

curl -sS https://get.pimoroni.com/scrollphat | bash -s - "-y"

but I can’t guarantee the process will complete successfully, there is something odd about your system, however that may have resulted.


#11

I was wrong before, towards update and upgrade, in any case I send the update log

pi@raspberrypi:~ sudo apt-get update Obj http://archive.raspberrypi.org jessie InRelease Obj http://archive.raspberrypi.org jessie/main armhf Packages Obj http://archive.raspberrypi.org jessie/ui armhf Packages Ign http://archive.raspberrypi.org jessie/main Translation-es_ES Ign http://archive.raspberrypi.org jessie/main Translation-es Ign http://archive.raspberrypi.org jessie/main Translation-en Ign http://archive.raspberrypi.org jessie/ui Translation-es_ES Ign http://archive.raspberrypi.org jessie/ui Translation-es Ign http://archive.raspberrypi.org jessie/ui Translation-en Obj http://mirrordirector.raspbian.org jessie InRelease Obj http://mirrordirector.raspbian.org jessie/main armhf Packages Obj http://mirrordirector.raspbian.org jessie/contrib armhf Packages Obj http://mirrordirector.raspbian.org jessie/non-free armhf Packages Obj http://mirrordirector.raspbian.org jessie/rpi armhf Packages Ign http://mirrordirector.raspbian.org jessie/contrib Translation-es_ES Ign http://mirrordirector.raspbian.org jessie/contrib Translation-es Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en Ign http://mirrordirector.raspbian.org jessie/main Translation-es_ES Ign http://mirrordirector.raspbian.org jessie/main Translation-es Ign http://mirrordirector.raspbian.org jessie/main Translation-en Ign http://mirrordirector.raspbian.org jessie/non-free Translation-es_ES Ign http://mirrordirector.raspbian.org jessie/non-free Translation-es Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en Ign http://mirrordirector.raspbian.org jessie/rpi Translation-es_ES Ign http://mirrordirector.raspbian.org jessie/rpi Translation-es Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en Leyendo lista de paquetes... Hecho pi@raspberrypi:~


#12

Hello

I have tried to perform an installation from 0. Without changing anything, neither updates, nor upgrade, just changing the file wpa_supplicant, to be able to remotely control the rasperry pi. In this case, the drivers have been installed, I have tried several examples and it works.

Now, afterwards, I changed the options to use my language, keyboard, time zone, Wi-Fi zone, and I expanded the file system, then I tried to install the phat drivers “Blinkt!” and failed error being the same “failed to update indexes Apt”.

Then I tried to leave the local configuration to the initial values (UK) but the result is the same, it is not installed.

I do not know if expanding the file system can cause this problem, but I do not think so, but if you want I make a clean installation and just change this.


#13

try the extended command I posted above. It should work.

incidentally, Raspbian jessie now automatically expand the filesystem on first boot, so it’s not a step you have to do manually (though nothing bad should happen if you do).


#14

Hi.

Finally it works: D, many thanks finally it has been installed and it works perfectly.

Already as a curiosity I tried to make a clean installation and fails when I change the configuration of keyboard, language, … to Spanish, I have to try and already out of curiosity an upgrade (without any previous change) and see what happens.
In any case now that I know it works I can go thinking about buying the phat microdot

Again thank you very much for the help, bye