Scrollphat not working anymore/


#1

Hi.

I had scrollphat working nicely on a pi zero. I used the sd card for something else and have now put another one in and installed VERSION=“8 (jessie)”.

i have done apt-get update and upgrade and enabled SPI and i2C but…

… whenever i try to run one of the example scripts i get this error…

Traceback (most recent call last):
  File "ip.py", line 12, in <module>
    import scrollphat
  File "/usr/local/lib/python2.7/dist-packages/scrollphat/__init__.py", line 8, in <module>
    controller = IS31FL3730(smbus, font)
  File "/usr/local/lib/python2.7/dist-packages/scrollphat/IS31FL3730.py", line 21, in __init__
    self.set_mode(self.i2cConstants.MODE_5X11)
  File "/usr/local/lib/python2.7/dist-packages/scrollphat/IS31FL3730.py", line 62, in set_mode
    self.bus.write_i2c_block_data(self.i2cConstants.I2C_ADDR,    self.i2cConstants.CMD_SET_MODE, [self.i2cConstants.MODE_5X11])
 IOError: [Errno 5] Input/output error

Any help or ideas please?
It had been working like a dream but now… it’s not :(

Cheers, Don


#2

How did you install it? git clone and sudo python setup.py install?

Can you try curl -sS https://get.pimoroni.com/scrollphat | bash
followed by a reboot?


#3

hi.

thanks for your tip. i’ve done that and i’ve got the same error. I’ve reformatted the sd card again and tried over but still the same problem.

from a fresh install of jessie i did an update and enabled i2c via raspi-config and then ran the code :

curl -sS https://get.pimoroni.com/scrollphat | bash

the response is:

Traceback (most recent call last):
  File "./ip.py", line 12, in <module>
import scrollphat
  File "/usr/local/lib/python2.7/dist-packages/scrollphat/__init__.py", line 8, in <module>
controller = IS31FL3730(smbus, font)
  File "/usr/local/lib/python2.7/dist-packages/scrollphat/IS31FL3730.py", line 21, in __init__
self.set_mode(self.i2cConstants.MODE_5X11)
  File "/usr/local/lib/python2.7/dist-packages/scrollphat/IS31FL3730.py", line 62, in set_mode
self.bus.write_i2c_block_data(self.i2cConstants.I2C_ADDR, self.i2cConstants.CMD_SET_MODE, [self.i2cConstants.MODE_5X11])
IOError: [Errno 5] Input/output error

? Thanks for any more pointers. Am I missing something or is my scrollphat dead :) ?


#4

It could be your soldering on the Zero or pHAT itself. The joints that matter are illustrated in this thread and I’d recommend giving them a makeover:

http://forums.pimoroni.com/t/phat-header-soldering-the-lazy-way/1690
(6 leftmost to be exact)


#5

thank you for your assistance with this.
i removed the scrollphat and noticed that one of the pins was loose.
i’ve now resoldered them all and it’s working.
since it had been working and fits so snugly i’d not thought to take it off and check the pins again.
thank you.
don