Fan shim - RPi4 not working


When I bought my first RPi4 (I own two, for the time being…), I bought it together the full kit, including the fan shim. When I assembled it, it ran a few days without any problem, the only thing I’ve noticed was that the fan was a bit noisy (it was running full speed).

Then I decided to install the script as described in the getting started, and everything was running, the LED changed colors, etc.

About three or something days ago I noticed that the LED was fixed red, and the fan was stopped. I reinstalled the software, changed the settings (temp ON and OFF), rebooted the entire thing but nothing seems to work. What I’ve noticed was that when I touch the shim, the fan seems to “want” to start, it spins one time and then stops for some moments, then it moves again and stops and so on…

The current setting is 55ºC for ON and 45ºC for OFF, and the board was running a bit hot at 74ºC… I’ve turned off the RPi and later I’m going to test it again. I have default Raspian Buster running, everything is updated and the service indicated that it was active and running.

Maybe the solderless fitting needs a bit of solder?


Try removing and reattaching the fan shim. It sounds like one or more of the GPIO pins aren’t making good contact with the shims through hole pads.

Thanks alphanumeric,

I’ve exchanged shims between my 2 (identically configured) RPi4s. Now, the one where the problematic fan was is working perfectly, and in the other isn’t working… It does the same. The LED works, the fan “threathens” to spin and stops, as if it hasn’t enough power to start…

I don’t really know what to do now… a bit of solder on the pins, maybe? I fear that might be a faulty fan/shim and solder is going to bring a lot of headaches…

My Fan Shim is soldered, but I soldered it to a female booster header. I can unplug it from my Pi’s GPIO header if need be. I just left out the two nuts that are used as spacers for the fan mount, so it sits lower in its holder.
Mine worked fine connected right to my Pi 4, I wanted to be sure it fully functional before I soldered it.
Sounds like a fan shim hardware issue. If it was software, the problem would stay with the Pi that originally had the issue.
The fan should spin while the Pi boots up and only switch to controlled mode when the Daemon loads. I don’t currently have the software installed and my fan just spins continuously as long as My Pi 4 has power. I’m happy with that as my temps just hover right around 40c. I don’t use the LED and the button works without the fan shim software.
If you take the Micro SD card out of that Pi 4, and power it up the fan should turn on and run continuously. If it doesn’t try tilting the fan shim slightly or pushing it down.

I’ve done all of that, I even bent the pins (just a tiny little) just to force the contact. The fan starts and stops all the same. But when I first bought it and installed it without software, it would run 24/7…

I guess I caught a faulty one :(

Ok, yeah, it sounds like it may have failed. Have you unplugged and reattached the fans JST connector?

My FanShim is dead silent. Is yours binding, twister, torqued, or something?

The software will set the fan On and Off at specific temps and works well. Only needs to be loaded once. Mine is set to the default setup and is inside my PiCade with the green LED illuminated. (PiCade hat needed higher spacers and a GPIO pin riser.)

– Chuck

I don’t think it is, even when the other one worked, it did the same noise. But is only when the on temp is achieved, it starts slowing down about 2 or 3 seconds after, so it’s fine. And it’s in a wooden furniture, so it has a bit more of resonance to it.

In the meanwhile, Pimoroni sent me a new fan shim, it’s on its way now.

One way to tell if its binding or rubbing is to gently flick the fan with your finger. Spin it. If its binding it will stop pretty fast. And with no motor noise etc if you listen closely you should be able to hear if one blade is rubbing etc. Turning it slowly with your finger should tell you if its rubbing etc.
I can hear my fan running, if the room is quiet and I listen for it. Just vary gentle buzz.


I have received a new fan shim last week, and I’ve tried it, and it works as it should… perfectly.

In the meanwhile, I’ve conducted a few tests myself. First, I’ve tried the fan of the non-working shim on a working shim: It didn’t work, it showed the same behaviour: The fan started to work and stopped, even when the RPi was booting - it wasn’t working.

Next, I tried the opposite: a working fan on the non-working shim… It also didn’t work, so I caught a dud. Neither components were working.

So, going back to the new working shim: after assembling it and testing it, it was very very VERY quiet… HOWEVER, my originally working shim is very very VERY noisy. So noisy, it almost seems my XBOX One X’s working…

I have not contacted Pimoroni regarding this yet, but I will.

For now, I’ve put the noisy shim on the least stressed RPi, but this is just a workaround.

Loosen the fan mounting screws and see if it quiets down. My shroud some how got out of round while I was messing with it. Spinning the fan with my finger I could see one fin touching the shroud on one side. A gentile pinch with my fingers made it round again and its been quiet ever since.