How to change volume up/down mappings with newer software version

#1

I’m wondering how to change the volume up/down buttons to the coin and 1up spots with the newer software. With the older software I’d modify picadehatd but that dosen’t seem to work.

Recently when I try to use the older version the install for the controls get an error “picadehatd is not a regular executable file” and the controls don’t work.

Edit: I’m still using the older Picade Hat also.

Thanks!

0 Likes

#2

I could swear I’ve seen people solve this somewhere before, but I’m remiss to find the posts.

The original Picade software would call out to the alsamixer command (in a roundabout fashion) to control the volume, but the new software behaves much more directly like a keyboard and doesn’t have this facility.

I think this post is on the right track, I might have to see if I can get it working: https://retropie.org.uk/forum/topic/17589/how-to-make-volume-up-and-volume-down-with-buttons

0 Likes

#3

Hi danimal,

If you’re talking about altering the system volume using buttons, you should be able to do this with the triggerhappy daemon.

I’ve been trying to set it up to adjust the system volume using a combination of hotkey and joystick, but I can’t get it to work. I’ve created a conf file with the keys and appropriate alsa commands, set thd (triggerhappy daemon) to run as the user pi, but no joy. It works perfectly when I run thd in a terminal, so my guess is it’s a permissions problem, but I’ve hit a brick wall with it at the moment.

I’m hoping you’ll have a go at it and find the solution for me!

Regards.

0 Likes

#4

Solved - it was a permissions problem. Nearly all the triggerhappy documentation says that you need to edit the following file and change “-- user nobody” to “-- user pi”:

/etc/init.d/triggerhappy

In fact you need to make the change in the following file:

/lib/systemd/system/triggerhappy.service

The thd daemon then runs as the user pi instead of the user nobody, and the commands that you’ve configured to run in response to button presses will work.

0 Likes

#5

I was able to get the old driver working in Retropie 4.4 by doing a apt-get update and then installing and uninstalling the new software and then installing the legacy software. Without any of those steps the volume controls won’t work. I still can’t modify picadehatd though without getting the "picadehatd is not a regular executable file” error so I soldered the pins on for BCM 13 and 26.

Edit: I got a very old driver version off an image I had from 2 years ago, before it was the legacy version and that has the same results in RP 4.4.

0 Likes