Picade Hat volume buttons not working


#1

Hi. I’m building a cabinet around a Pi 3B and a Picade Hat (original version, not X). So far everything is working fine except the volume buttons. I soldered pushbuttons to the GPIO 13 and 26 pads on the Hat (and ground ofc).
Audio works fine through the Hat, but the volume controls do not. They have no effect in Emulationstation or within Retroarch (lr-mame2003). I am using Retropie 4.4

Any idea what to check/how to fix?


#2

You should install the legacy Python driver in lieu of the newer one for Picade X HAT. I’d completely forgotton that it supported volume control on 13/26.

There may be a way to add support without going for full-on driver replacement, though.

Try adding this to /boot/config.txt

dtoverlay=gpio-key,gpio=13,keycode=114,label="Volume Down"
dtoverlay=gpio-key,gpio=16,keycode=115,label="Volume Up"

#3

Thanks for the quick reply. I tried adding those overlays to boot/config, still doesn’t work.
I installed the HAT using:

curl -sS https://get.pimoroni.com/picadehat | bash

How would I go about installing the legacy driver?


#4

I figured it out. Here is the process for others experiencing the same problem:

Uninstall the new driver:

cd /home/pi/Pimoroni/picade/picade-hat
sudo ./uninstall.sh
sudo reboot

Make note of the changes this makes to your /boot/config.txt in case it breaks something you did purposefully.

Install the legacy driver

cd /home/pi/Pimoroni/picade/picade-hat/legacy-python-driver
sudo ./setup.sh
sudo reboot

Worked like a charm for me:)