PICADE - X Hat- Buttons + Joystick not detecting


#1

Just received my new Picade kit on friday, and first of all just want to say I’m really happy and impressed with the quality of the kit.

I have run into a bit of a snag though.

Built the kit, installed a fresh version of Retropie and began the configuration process.

However I’m unable to recognize or map controls for my joystick or any of the 10 other buttons, nor will the power button on the side shutdown the system.

System is able to work with a USB controller or keyboard, but unable to get the other controls to recognize. I’ve attached, and re-attached the x Hat a few times to ensure the connection is good, reinstalled all cables, rebuilt my SD card image and went through the install package 3x and have run into the same results,

I’ve verified the directory installed, and adjusted updated my config.txt file properly, but beginning to wonder if i have a bad board, or if theres something else that isn’t properly configured?

Thanks


New Picade setup - no sound or joystick detction
#2

Double check you have the plug on the joystick plugged in the correct way.


#3

verified, disconnected and re-connected all the controls and no luck.


#4

Ok, that seems to be a common error thats easily fixed. I don’t have a Picade or Picade Hat.
What model Pi, if its a Zero header soldered on OK?


#5

The same problems for me. I am getting nervous. I have a pi3b+


#6

Have to ask the obvious, Picade hat firmly pressed down. It requires a bit of pressure to seat the GPIO pins in that low profile header. If you mounted standoffs it should be level with and parallel to the Pi.
Nice beefy 2.5A power supply? Power supply connected to the Pi or the Hat, not sure it matters but going to ask anyway?


#7

Great. Reinstaling the gpio i solved the problem. Now I have another problem, my adaptor is 2.5A but is not the official. When I turn off the picade with the power button its appear a ray logo, and the screen stops with the letters low power shut down. It continius unil a disconect the plug

What is my problem? Do I need the official charguer?


#8

Lightning bolt? If yes thats the low voltage warning.


If you see this ICON in normal use thats not good. Why your seeing it on shutdown I don’t know?
What can happen is under high current draw, you get a voltage drop across your poser cord. If it’s enough of a drop it will trip the warning. The other thing that can happen is, as you approach that 2.5A limit, the power supply voltage will drop, as a safety feature to prevent you from exceeding the max current limit.
Some Pi supplies are 5.1 or even 5.2 volts out so you get a nice reliable 5V at the Pi.
I’m of the opinion that even te official 2.5A supply is iffy with a Pi 3B+ and any heavy load Hat that wants a lot of current to work.


New Picade Joystick and Buttons do not work
#9

And what can be a solution? buying another charged???


#10

If your seeing it all the time, yes get a better power supply. I run a 4A on one Pi setup I have, and a 10A on another. These supplies use barrel connectors so I had to use an adapter. 10A is overkill but its my breadboard setup that may have motors or servos connected. Or other high current devices.
https://www.adafruit.com/product/1466
https://www.adafruit.com/product/610


#11

Mines properly seated - have reseated it a few times, even took the standoffs off to ensure they weren’t sitting too high. The speaker is working, and the power on button works- but as stated its the joystick, arcade buttons and power off script will not function.

Pi3b+.
Using a Cannakit 5v 2.5a power supply for the Pi3b+, running through the hat supplying the Pi.
Have even tried running the display off a separate USB power supply to make sure it wasn’t drawing too much.


#12

Solved again. I but the officil charguer and the ray and limitations dissapear.

Thanks for your help


#13

Now I have another problem. Just put a sd card with a retropie image, perfectly installed with all type of roms , so when I configure the joysticks it came crazy, the 1up button is like hotkey. The select button convert into save and load state. Etc

Its recognized like a keyboard with the instructions of a keyboard

So its impossible to play

Also the last problem is when I turn off the pi with the button, the screen freeze with poer down, but the screen continue on. So I have to unplug the cable. It was not supoosed to do it automatically?


#14

You’ll have to wait for somebody from Pimoroni to chime in, I don’t own a Picade. @gadgetoid


#15

Yes the Picade controls are set up as keyboard inputs, but if you step through the control configuration in RetroPie they will function fine in the menu/games.

The HotKey button is whichever button you configure as HotKey. I changed mine around recently because I kept screen recording, and now it works pretty well.

These are how I currently have mine set up:

[LT] /--------------------------------\ [RT]
           [U]           [B] [Y] [RS]
        [L][D][R]      [A] [X] [LS]
     \--------------------------------/
        [START]             [SELECT]

with LT (Left Trigger) as the hotkey enable since I had trouble with it on SELECT since it kept entering recording mode.

This makes [LT] + [START] exit, and [LT] + [X] go into the emulator config menu, which are both super handy.

Since virtually no Arcade-style or classic consoles had Left/Right triggers (just left/right shoulder buttons on the SNES, GBA) it’s usually the best choice to reuse one of these.


#16

I have the same problem, but on a Raspberry Pi 3b (not the b+). I am using the official Raspberry power cable.
Power on with the power button works, but all other buttons and the joystick cannot be detected in the Control Configuration in Retropie.
Power off does not work either. I could not verify if sound is working.
X Hat sits tightly and parallel on/to the Raspberry Bi 3b.
Could it be that the X Hat is defect?


#17

Steps for debugging hardware:

  • drop to terminal from ES by hitting F4 (you will need a keyboard!)
  • install wiringpi for the gpio utility: sudo apt install wiringpi
  • run watch -n 0.1 gpio readall to watch your GPIO status
  • hit some buttons, twiddle the joystick (slowly, 0.1 is a tenth of a second so any action <0.1s may not be visible) and see if anything changes

It’s possible that the dtoverlay/drivers/etc for the controls aren’t loading properly, to debug the software:

  • Make sure /boot/overlays/picade.dtbo exists
  • Make sure dtoverlay=picade is in /boot/config.txt
  • Check dmesg output for any glaring errors
  • Check that /etc/udev/rules.d/10-picade.rules exists

#18

Yes, I do that configurations but when I start a game and press por example select, it goes back to the menu screen. Also if a press start it says " recording in pi/…" . If a press RS , it says “Fast forward”.

These are my problems, I have the same configuration as you. In the menus it is perfect, but when I try a game this happens.

Maybe is a retropie problem, because it thinks I am using a keyboard no a gamepad at games

Anything I can do?


#19

I’d say rebind your controls and make sure to skip either Left Trigger or Right Trigger and explicitly bind a hotkey. Sounds like you might have let RetroPie pick a default, which can be problematic.


#20

Yes , rebindings keys continue the problem. All the time in all games it recognises it as a keyboard. I tried differents things but without a solution. I am desesperate because I cant play with my picade