New Picade setup - no sound or joystick detction


#1

Hi There-

I have completed the Picade setup and the hardware looks great. I plugged in my existing retropie 3 system and simply added the picade Hat to it. When running in the Picade console, I get absolutely no sound and no recognition of the joystick at all. However, there are no problems with video which looks great.

To validate that its not an issue with the retropie itself, I retested by plugging in my TV monitor (hdmi) and used my usb controllers all works fine - video, sound and controllers recognized.

My suspicion was likely configuration settings since I’ve confirmed I can actually get it to play correctly just with different HW. I’d really appreciate any ideas to try or investigate something I haven’t checked. Thank you!

Here’s what I tried:

  1. Audio
  • checked physical wiring connections
  • switched red/black (+/-) connections in case they were backwards
  • emulation station sound settings - tried changing audio device - PCM (default), Master, Speaker
  • retropie audio configuration - tried Auto, 3.5 headphone jack, Mixer (not sure what that does),
  1. Joystick
  • Emulation station settings
  • Configure Input -Picade Joystick is not detected at all - Tried pushing all buttons. Keyboard and other USB controllers are recognized automatically

What is OMX player audio device? (default set to both). options are: ALSA:HW:1,0, ALSA:HW:0:0, Local, Both


#2

After some helpful debugging tips from @Gnurou in discord chat and from this post PICADE - X Hat- Buttons + Joystick not detecting, I tried the additional following steps, but did not get further in solving the issue. However, have more details that might help ID the cause.

  1. Reinstalling picadehat script install and rebooting. (curl https://get.pimoroni.com/picadehat | bash)

  2. output of “ls -l /sys/class/input/” https://clitxt.com/t/vp9-1537337922.txt - expect to see gpio-keys device there, but don’t

  3. Steps for debugging hardware:

  • drop to terminal from ES by hitting F4 (you will need a keyboard!)
  • install wiringpi for the gpio utility: sudo apt install wiringpi
  • run watch -n 0.1 gpio readall to watch your GPIO status
  • hit some buttons, twiddle the joystick (slowly, 0.1 is a tenth of a second so any action <0.1s may not be visible) and see if anything changes

< I did see some activity when hitting buttons from the console, so that was a bit promising. Joystick only registered some activity when moving up. lt, rt, down didn’t see any activity.>

  1. It’s possible that the dtoverlay/drivers/etc for the controls aren’t loading properly, to debug the software:
  • Make sure /boot/overlays/picade.dtbo exists
  • Make sure dtoverlay=picade is in /boot/config.txt
  • Check dmesg output for any glaring errors
  • Check that /etc/udev/rules.d/10-picade.rul

Here is output from “dmesg” command: https://clitxt.com/t/2ck-1537335849.txt


#3

What’s the output of lsb_release -a and uname -a - I believe your RetroPie image may be a whole distribution out of date, and missing some required components.


#4

Output:
No LSB Modules available.
Distributor ID: Raspian
Description: Raspian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: Jessie

uname -a
Linux retropie 4.4.50-v7+ #970 SMP Mon Feb 20 19:18:29 GMT 2017 arm71 GNU/Linux

What is the easiest way to upgrade? I didn’t build the image myself, so I can’t reproduce it from scratch.


#5

If your stick registers the up movement but nothing else, try plugging in the joystick connector the other way around on the hat.


#6

thanks - i tried reversing the connector as suggested but it did not do anything


#7

@gadgetoid - thanks for the tip on upgrading retropie. After upgrading to 4.4, sound started working! Joystick is still unresponsive. One thing i saw at the end of the upgade was a screen display the error: “Error running ‘git pull’ - returned 1”. This made me want to check the logs (which should do anyway) to verify the installation went ok.

(screenshot)

Logs from retropie-setup viewable here: https://clitxt.com/t/r3r-1537477240.txt

A quick grep for ‘error’ in the logs pointed me to these two items:

Number 1
= = = = = = = = = = = = = = = = = = = = =
Configuring ‘retroarch’ : RetroArch - frontend to the libretro emulator cores - required by all lr-* emulators
= = = = = = = = = = = = = = = = = = = = =

error: Your local changes to the following files would be overwritten by merge:
shaders/2xsal.glsl
shaders/crt-pi-vertical.glsl
shaders/crt-pi.glsl
shaders/nedi-jinc-pass2.glsl
shaders/nedi-pass0.glsl
shaders/nedi-pass1.glsl
shaders/super-2xsai.glsl
shaders/super-eagle.glsl
stock.glsl
Please, commit your changes or stash them before you can merge.
Aborting

Number 2

Copying new default configuration to /opt/retropie/configs/all/retroarch.cfg.rp-dist
/home/pi
Error running ‘git pull’ - returned 1


I’m not sure what these pertain to. Hopefully they are related to the joystick detection issue. Any feedback appreciated! Thanks!

Also - I re-ran diagnostic checks after the upgrade after the upgrade to retropie 4.4. Here are the results of some initial observations:

1. Here is entire output from the “dmesg” command after retropie upgrade to 4.4

Quick grep for ‘gpio’ found a few things:

[ 0.086866] uart-pl011 3f201000.serial: could not find pctldev for node /soc/gpio@7e200000/uart0_pins, deferring probe

and

[ 2.599507] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 2.600890] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 2.601410] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 2.732767] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 2.737675] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[ 2.738059] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 2.742789] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 2.743957] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 2.785437] snd-hifiberry-dac soc:sound: pcm5102a-hifi <-> 3f203000.i2s mapping ok
[ 2.789588] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 2.991742] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe
[ 3.000811] usbcore: registered new interface driver brcmfmac
[ 3.001159] gpio-keys gpio_keys: could not find pctldev for node /soc/interrupt-controller@7e00b200, deferring probe

  1. watch -n 0.1 gpio readall (o qtch gpio status)

All the buttons and Joystick UP register activity. however Joystick down, left, right do not register.


#8

Had the same issue. Joystick is connected the wrong way around. Plug in the joystick the other way round. That should fix your issue


#9

thanks for your response @rob. as I mentioned above, I tried that but it didn’t help.


#10

I’m having the exact same problems. I just finished building the Picade last night. No sound and only joystick “up” only registers when configuring buttons. Left, right, down, does not register at all. I tried 2 different boards, raspberry pi 3 And 3B+ with the same results. No sound and joystick issues. Maybe our boards are defective?


#11

@metalx I hear ya. I’ve just about given up on this thing. I bought this over a month ago and have spent more time on it than its worth. Its a shame because I really am vested to see it work as I like the hardware. i tried reaching out to support as well - they couldn’t really help much. if you have any suggestions - open to hearing them. i’m going to try other images to see if its a compatibility issue with the software.


#12

I got it to work yesterday. I reinstalled retropie from scratch on a Pi 3B+ and updated it which fixed the sound. I then bought a brand new Sanwa joystick on amazon and replaced the stock one. Search for SANWA JLF-TP-8YT-SK OEM Red Ball Top Handle Arcade Joystick 4; 8 Way Adjustable (Mad Catz SF4 Tournament Joystick Compatible). Initially after installing the new joystick, left right down still didn’t work. But I then flipped the cable on the hat and it fixed the problem. I tried flipping the cable with the old joystick before but that did not work last time. For my case, I think the supplied Picade joystick BLEE is cheap and defective. The Sanwa joystick is a better quality joystick. It ran for about $25. Everything works well like it should. I’m also using a NorthPada Power Supply 5V 3A to power the picade.

I’m pretty rusty when if comes to software diagnostics and coding, but if you need me to run some test I can do that for you. Just gotta tell me how to do it.


#13

New 2018 Picade owner here. I’m having the same issue with anything connected to the picade hat is not working (sound, power button, joystick, buttons).

The GPIO status shows button activation and joystick movement, but emulation station will not read it all and I’ve got no sound either. In order to power it, I’ve had to plug the power supply directly into the Raspberry as I can’t turn it on at all when plugging directly into the HAT. Any help is appreciated.


#14

Generally if you’re having any problems with input/sound and you’re using an old SD card from another arcade build, you should write a new SD card with the latest version of RetroPie. Most of these issues seem to stem from the older underlying OS (Raspbian) being significantly out-of-date and not compatible with the way PicadeX/2018 does things.

While it’s possible to update an existing SD card, I’d recommend backing up games/settings and reflashing, or imaging a new one entirely.


#15

I did do reformat of the SD card and used the latest Retropie, but was still having the same issues. I assume the best way to wipe the card for a new image file is to use Windows? I’m not sure if that is completely wiping the card.


#16

Curious- with your RetroPie setup booted what’s the output of dmesg (you may need to plug in a keyboard and hit F4 to get to the console and enter this command)?


#17

Stupid question: how can I get the log output to you? Does it get saved on the SD?


#18

You can dmesg > log-output.txt or you can snap a photo, since usually the latest errors are the ones that count after a fresh boot.

Additionally the output of lsb_release -a and uname -a would be useful.


#19

I downloaded a new retropie image from https://retropie.org.uk/download/, flashed it to a micro sd card and booted it up on picade. Upon booting, I see “no input” displayed on the screen, then the screen goes black. I should see emulation station boot up. If I take that same image and run it on a standard pi3, I see emulationstation boot up.

I’m stuck. Please help.


#20

You need to add a line to your config. I forget exactly the syntax, but it is the hdmi hotplug line. If you check the Picade errata or do a search here in the forums, you should find it.