Picade with 3A+ issues

#1

EDIT: It turns out I’m a bit of a dumbass! The speaker cables weren’t seated properly in the Picade X HAT (although they looked to be). Some wiggling with the wires fixed this… Doh!

I bought the Picade recently and a Pi 3A+ to run RetroPie on it. I checked with the guys at Pimoroni before taking the plunge and they said the 3A+ should be fine but may need a bit of cable swapping during setup (due to the single USB port).

I ran into a few issues, mainly down to the lack of support in the latest RetroPie image, which does not work out of the box on the 3A+. On initial boot, I was stuck at the rainbow splash screen and nothing happened.

I eventually found a thread on Reddit that explained that the base image on RetroPie needed some updates so I ran the following on my Pi 3 (I swapped out the SD card to run the below):

sudo apt-get && sudo apt-get dist-upgrade-y

Then:

sudo rpi-update

And then on the next boot - on the 3A+ - it booted fine! Progress.

Next steps was to install the Picade X HAT software, so I ran the recommended command:

curl -sS https://get.pimoroni.com/picadehat | bash

And the followed the recommendation to reboot.

On the reboot I was taken back into RetroPie where I was able to configure the input using the joystick etc. More progress.

I was able to get everything up and running but when I ran any game, there was no sound at all. Nothing.

I tried changing settings in the UI in EmulationStation but nothing worked - no sound whatsoever. I’ve also checked the physica l connection between the speaker and the Picade X HAT and the wires are definitely secure.

I’ve looked online and stumbled across a couple of similar threads where nothing seems to have worked. I’m really frustrated!

My config.txt file has the parameters set as per the Picade X HAT install script (confusingly, there is a dtparam=audio=on as well as a dtparam=audio=off in the last section in my config, but commenting them out in different combinations does not work either).

So I was hoping that somebody like @gadgetoid or @sandyjmacdonald etc at the Pimoroni crew could offer some insight?

0 Likes

#2

I do believe dtparam=audio=on and off applies to the onboard alsa audio? Which on the 3A+ would be the HDMI. So I think you want to remark out the dtparam=audio=on line. And there should be another entry enabling i2s, which is what the picade hat uses to get the digital audio signal from the Pi.
dtparam=i2s=on I think?
And a dtoverlay=(picadehat or something)?
I don’t own a Picade, I do own several Pi3A+'s but they are all currently running Motion Eye OS.

0 Likes

#3

Thanks. I’ll give that a go later. I assumed the Picade installer would have sorted everything automatically though?

0 Likes

#4

Yes, it should do all that on its own. Can’t hurt to have a look see though. For some reason I was originally thinking the 3A+ didn’t have analog audio out? I see that it does so its not that thats messing things up. Unless the installer is specifically looking for a 3B? I wouldn’t think they would do that though. Phil or Sandy will likely chime in tomorrow some time when they are back behind thier desk.

0 Likes

#5

Ok, so just tried that and nope. No sound still. I added the following line in my config.txt:

dtparam=i2s=on

And also commented out:

dtparam=audio=on

But no sound still. So frustrating.

0 Likes

#6

I do believe there should also be a dtoverlay= statement in there too somewhere?
Pointing to the Xhat or the sound chip on the Xhat.

0 Likes

#7

Found this
https://www.mathworks.com/help/supportpkg/raspberrypi/ug/play-high-quality-audio-from-raspberry-pi-using-i2s-based-dac.html

0 Likes

#8

Just curious why you used a 3A+ instead of a 3B or 3B+?
You do know the 3A+ only has 512 megs of ram?

0 Likes

#9

Sorry, I meant that the parts I added are in addition to what the Picade one-line installation script adds. That includes the overlay for the Picade X HAT.

I chose the 3A+ because it should be more than adequate for an arcade setup. 512MB RAM is more than enough really. I’ve not tried with a 3B+ yet as that one of mine is in use so would require more faffing.

0 Likes

#10

Ok, was just wondering. I just recently ordered a couple more 3A+'s. One is going to free up one of my 3B+'s for other things. I’m using the 3A+'s for my motion eye web cameras. They run headless over WIFI so I don’t need all the extra ports that are on a 3B. I have a USB hub that has an ethernet jack that works a treat for setting them up. I can get a 3A+ and a PIBOW case for it for less than what a 3B+ would cost.
Until now I’ve been using A+'s and Zero’s for most of my headless setups.

0 Likes

#11

Only other thing I can think of to try is another speaker. And double check that the speaker wires aren’t pushed too far in the Xhat speaker terminals. Push them in too far and the contacts might be sitting on the insulation instead of the bare wires.

0 Likes

#12

Ok, so I’ve tried the speaker connections again and they seem to be fine - no sound still.

I figured I may be asked, so here’s my config.txt as it stands right now:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835) -- EDITED TO TRY AND GET PICADE WORKING
#dtparam=audio=on
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1
dtparam=i2s=on
dtoverlay=picade
dtparam=audio=off

So the changes I’ve made to the above (after the Picade script has done it’s stuff) is to add the dtparam=i2s=on and commented out the dtparam=audio=on (so it’s now showing as #dtparam=audio=on.

0 Likes

#13

You need somebody else with a Picade to post theirs. Then go from there.

0 Likes

#14

Ok, some progress. I just swapped out my 3A+ for a 3 and boom - sound works straight away, no change to any settings. Something is definitely different for the 3A+ then! Hopefully this will help @gadgetoid and / or @sandyjmacdonald (or anybody else that might see this).

0 Likes

#15

That was good thinking. Do you have another 3A+ by chance? That would determine if its a hardware or software issue.

0 Likes

#16

No, I don’t. First one I bought. I’m going to triple check it’s not something with the speaker wires connection again, just in case!

0 Likes

#17

Hey @alphanumeric (and also @gadgetoid and @sandyjmacdonald), guess what? Guess who’s won the dumbass of the day award? You got it, me!

It turns out that the speaker cables weren’t properly seated in the Picade X HAT after all! I’ve just switched back to my 3A+ and voila, sound! The connection on the Picade X HAT isn’t fantastic, but with some wiggling with the back off the Picade, I’ve now got sound out of my 3A+ as expected. What a silly mistake!

Anyway, this is a redundant post - I’ll edit to say, but thanks for your time and efforts anyway. On the positive, I’ve learnt a lot about I2S sound cards…

0 Likes

#18

Stuff like that happens, been there done that.
The Phat Beat uses those same speaker connections. I made sure to strip the bare wire back a good deal and tin it with my soldering iron. I used my own speakers. I press down on the release tab with a small flat screwdriver when inserting my speaker wires. Like you do to remove them only not pressing as hard. The wire bit then slides in easily and you can tell when the insulated part hits. Back up a little and release. IMHO, the screw terminal connectors are better for the novice. They have a taller profile though so I can see why they went with the friction fit terminals.

1 Like

#19

I’ve learned tons just trying to help others, even when I don’t own said doohickey. ;)
I’m retired with way too much free time on my hands lol. =)

0 Likes

#20

Yeah, the connectors aren’t the best if you ask me. I much prefer the screw terminals - appreciate the DuPont connectors are better for a novice, but I’ve actually had one of the pins break off and get stuck in the Picade X HAT due to the fragile nature of them when I was assembling the FINAL bolt in the Picade build (I’ve already emailed the support team about this actually) - fortunately it was “only” for the LED in the power button, so apart from it not lighting up, everything does work, but it’s not ideal.

If I had the choice, I would have opted for screw terminals on the Picade X HAT.

0 Likes