Picade 2018 - No sound from Speaker


#1

Built my Picade 2018 cabinet with a Raspberry Pi 3B+.

RetroPie boots and I’ve installed the Picadehat drivers using curl https://get.pimoroni.com/picadehat | bash. Rebooted and can set up the Joystick and buttons but I get no sound.

When I go into the sound settings in the main menu the audio is set to 0% and will only remain above that if I select the audio device as PCM. Speaker or Master all reset to 0% as soon as I exit.

Even if I wipe the SD card and reinstall RetroPie and the Picadehat drivers when I go back in the audio settings the volume remains at 0%.

Any help? The speaker is cabled up correctly i.e. red wire to + and black to - on the picadehat, and I had the sound working at one point when I swapped the pi out for an older model to test.

I’ve added my Config.txt below.

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default "safe" mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

#disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16

#overscan_right=16

#overscan_top=16

#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280

#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1

#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.

#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on

#dtparam=i2s=on

#dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on

gpu_mem_256=128

gpu_mem_512=256

gpu_mem_1024=256

overscan_scale=1

dtoverlay=picade

dtparam=audio=off