No sound from speakers


#1

Hello, I have recently built the picard using a pi 3 model b. When I play a game on retro pie it doesn’t play any sound. I set the audio to go through the 3.5mm jack in the cmd line as well as in retropie audio settings. When I plug my headphones into the pi I hear nothing and when the aux cord connecting the pi to the speakers is disconnected the speakers emit a low hissing sound.

–Any and all help is greatly appreciated.


#2

Make sure you have the 3.5mm jack cable going from the Picade PCB to the Pi. If you have, try swapping the positive and negative speaker wires around so the black wire goes were the red wires goes and vice versa. If that also doesn’t work try adding disable_audio_dither=1 to the boot config. If all else fails buy a shielded 3.5mm jack cable. Hope this helps.


#3

I hate to be the one to say it, but is the volume turned up on the Pi? There’s an option for it buried somewhere in EmulationStation but I can never remember where.

Disconnecting the speakers will most likely leave them to hiss- the amp will be interpreting random environmental noise as a signal :D


#4

I was wrong, when I tested it again I do hear sound coming from my headphones when they are plugged in. After I switched the speaker wires(recommended above) I now hear sound from the speakers when I plug the aux cord in, but then it gets quieter very quickly till its silent.


#5

This might be a fault with the Picade PCB. Could you possibly post a photo of your board, paying particular attention to the audio input jack? Do any of the connections on the jack look lifted from the PCB at all?


#6

I hope this picture helps, nothing on the PCB seems “lifted”. If you need another angle, please let me know.


#7

Hi Mingee23,

Were you able to get this resolved? I’m having a very similar problem and I’m trying to figure out if your issue was resolved.

In my case, audio works if I plug in separate headphones, and the speakers themselves work if I plug them into another device (my 3DS), however when plugged into the Raspberry Pi, no sound at all.

Hopeful your situation was resolved and might be helpful to my own.

NightOwl


New and need help. Kickstarter Picade board problems
#8

there are several possible causes. I would suggest you try flashing the firmware that does away with headphone detection. To do so, run:

curl https://get.pimoroni.com/picadefw | bash

choose option 1 (no headphone detection)


#9

This did the trick, thank you for your response and assistance, it is greatly appreciated!