Picade HAT audio via HDMI?


#1

Hi,

I have just today installed and loaded the software for my Picade HAT onto a Raspberry Pi 3B+ for the main purpose of wiring up a power button, which works well.

Sound was working fine to my monitor before I rebooted (after installing the picade software) and now I do not get sound? I assume it is because the software has changed something to redirect sound to the Picade HAT audio terminals? How can I change just those settings back so the sound comes back out via HDMI?

Sorry if this has been asked before, I could not find it anywhere I searched.

Thanks!


#2

You should edit /boot/config.txt and change #dtparam=audio=on to dtparam=audio=on IE:: uncomment it. Or remove a line dtparam=audio=off if it exists.

The software also changes /etc/asound.conf which you can safely remove or rename to /etc/asound.conf.hp4


#3

Awesome thank you I will try this tonight. I did the first part but that did not seem to make any difference, but I have not tried renaming the asound file so I am sure that will do it.
Thanks again!