Picade Console -- audio issues


#1

Hey folks… Relatively long time user of RetroPie on RPi 2 and 3 B.

I was very excited when I discovered this place and Picade Console. Really great little piece of kit

I followed the build instructions completely, everything booted. Did a full install from scratch as per the recommendations. The important point is at this point I knew i had sound.

Running latest retropie 4.4 (fully updated as well)

Once I ran the pimoroni script installation step I lost ALL sound. HDMI, 3.5mm – nothing!

A quick point – i didnt bother installing the on board speaker because quite honestly i didnt care for it. I really only will be playing where I have sound through the TV or through a 3.5mm speaker hookup. (So that is not a reasonable workaround for me)

I have no idea at this point how to even debug this and would appreciate some help. I’ve never had this kind of problem before.

… also one final point, I did do a full re-install as well. Same thing – installed, had sound, ran pimoroni install script, lost all sound.


#2

The Pimoroni install script sets the audio to i2s and feeds the amplifier and speaker on the Picade. Hook the speaker up and you should have sound from it.
To get it back to HDMI likely means a config.txt edit. You may be able to toggle it back by running raspi-config from the command line?

If you run sudo nano /boot/config.txt and look at the contents that may tip you off to what you have to edit or remark out. I don’t own a Picade and don’t have a Pi booted up at the moment to check mine. I’ll boot up one of my stock installs and have a look see latter on if you want.


#3

Thank you… if you can i’d appreciate it… I’m going to cross post this to the support channel here. (Its my first post so not sure where to write things)


#4

This is what I have on my Pi thats is using the Pi foundation 7 inch touch panel. I have HDMI selected vis the sound icon in the tray. Its full Raspbian, latest edition as far as I know. Lines with a # at the beginning and just comments and do nothing. Normally I would have analog audio set as my source. I double checked and it was set to HDMI. Must have forgot to change it after my last fresh install.
Ignore the dtoverlay=i2c-rtc,ds3231 line at the end. I have a DS3231 RTC installed.

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

#disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

#hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on
dtoverlay=i2c-rtc,ds3231


#5

Thank you! I will review this when i get home this evening.