Picade - failed to attach default card


#1

I’m hoping someone can help as Ive spent a few hours trying different solutions but with one result - no sound.

2017 Picade kit (not the latest) and used the video for the setting up the new picade (found at https://www.youtube.com/watch?v=gTgu1fUVsmw). From what I can tell, the picadehat and picadehatx have the same drivers so shouldnt be any issues here.

Essentially I am getting no sound. When I go to Retropie > Audio I get the following appear on the screen for a second
lv10: volumecontrol::init() - failed to attach default card!
ALSA lib pcm_dmix.c:1052:(snd_pcm_dmix_open) unable to open slave
lv10: AudioManager Error - Unable to open SDL audio: ALSA: Couldn’t open audio device: No such file or directory

I then select “Headphones - 3.5mm jack”

When I go to Emulationstation settings > Sound Settings if I change the volume, it always goes back to 0% when I leave this screen and return.
I have been told that Audio Device = PCM

My assumption is either its something I have left in the config file or an issue with the sound driver and am pretty sure its something straightforward that at a glance someone will roll their eyes and tell me where I am going wrong

Any help would be really appreciated as I am close to giving up.

Thank you

Config file:

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

#disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

#DMT (computer monitor) modes
#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1
dtparam=audio=on dtoverlay=picade
hdmi_force_hotplug=1


#2

Groan! This isn’t going to help. You must have run the installer while it still had that bug.

Edit those lines so there’s a linebreak between them like so:

dtparam=audio=on
dtoverlay=picade

#3

Thank you gadgetoid

That seemed to solve the driver issue (was using notepad to edit instead of wordpad so couldnt see formatting). Retropie has since started behaving oddly and attempting a reimage. I have however discovered that my SD card is one of the cards that can have issues using a Raspberry Pi so might need a new one.

Once again, thank you for your help