New Picade - audio problem - volume stuck at 100%?


I’ve just got a new 8-inch Picade (the one with USB-C XHAT) and - aside from a faulty power switch, which i’m currently bypassing - all is well, except that I can’t change the volume! It’s very loud, which is rather distracting when you’re not the one playing on it! :)

I’m using a Raspberry Pi 3 and have used RetroPie 4.7.1

When I try to go into RetroPie’s audio settings a message (error?) briefly appears that reads:
lv:10: Volume control::init() - Failed to find mixer elements!

Then the blue/grey audio settings screen just reads:
On-board audio disabled or not present

Changing the volume using the Picade’s little buttons (the ones that bring up an OSD) have no effect, but I don’t even know if they’re supposed to…? Should they…?

Many thanks in advance.

1 Like

I’m having the same problem on a fresh install of RetroPie 4.7.1 onto a Rpi3 with the 10" Picade.

Audio worked as you describe (stuck at 100%, “failed to find mixer elements”) So I reinstalled the SD card and now I have no audio at all, and both of those odd system messages.

I’m guessing RetroPi 4.7.1 is not compatible with PiCade? I will re-image with a lower version of PiCade and see what happens.

I hope they can find a fix soon.

Hi @maehem, did you have any luck with trying an earlier version of RetroPie? I haven’t had opportunity to try that yet.

It turns out that you can’t get earlier versions of RetroPie. They don’t allow it.

I did go into /boot/config.txt and re-enable the ALSA sound and try to use those. But even though I can adjust settings for it in the RetroPi menu now, there’s no audio output with any combination of settings I’ve tried. What bothers me is that it went from having audio but not being able to adjust volume from when I first set it up, to now, no audio at all, even if I refresh the SD card, reinstall Picade and start fresh. I’ve spent way too much time on this at this point, so I will wait until one of the Pimoroni engineers figures this out.

Sorry to hear that, @maehem

Just FYI, I’ve found this post pinned to the top of the RetroPie support forum:

Fingers-crossed there is a solution within!

None of that worked for me.

There’s a workaround in this post

Thanks @roundy. Probably is worth pointing everyone at the other thread on this.

true, but that thread isn’t in support and is marked as solved while this problem is far from solved :)

Cross posting from the other thread!

1 Like

This worked for me.

It would however be really nice if a manual button control could be reimplemented.