Odd Audio Problem with Original Picade


#1

I have an original Picade from the Kickstarter, and I have a weird audio problem:

  • When I run the Picade and plug the audio cable into my phone, I hear my phone’s audio through the speakers, so the speakers work
  • When I plug headphones into my Raspberry Pi’s audio jack, I hear audio from the Pi, so audio out from the Pi works

But when I plug the Raspberry Pi into the Picade speakers with the Picade’s audio cable, I don’t get any audio. Nothing at all.

Any clues what might be going on?


#2

Tried holding the volume buttons up? Seriously, I fell foul of this.


#3

That sounds like it might be my problem, particularly because I have no idea where the volume buttons are. I can see that newer Picade PCBs have connections for volume control, but on my old Kickstarter PCB, none of the connectors are labelled for volume control. Any ideas?


#4

Not sure about that, also make sure you’ve forced the audio to output from the 3.5mm jack and not HDMI. There is a setting from the config.txt and within Retropie itself.


#5

I wanted to follow up in case anyone has the same problem. I ordered the new PCB from Pimoroni, and replaced my Kickstarter one. Indeed, with the new PCB, I could now increase the volume, and sound would be audible through the speakers. Volume wasn’t saved when the PCB lost power, but after updating to the 2.3 beta version of the Picade firmware, everything seems to be working fine now.

I got the beta firmware here:

In hindsight, I now realize that I could probably have accessed the software on the old PCB directly, and changed the volume that way (or possibly figured out what the problem was, if volume wasn’t it), so if anyone else has the same problem, this would be a good place to start.

You can get the firmware for the original Kickstarter PCB here: