Sound issue with early Picade hardware after RetroPie upgrade

I bought an early version of the Picade back in December 2015.
After many years without an issue, I thought that it was time to upgrade to the latest RetroPie version, as the legacy Raspbian Stretch is no more maintained.
Everything went smoothly except for one single issue which I have not been able to solve, even after spending a few hours testing it in many ways: my Picade delivers no sound anymore!
The issue is not only with RetroPie but a general one. Fors instance omxplayer can play a mp3 file but no sound exits from the speakers connected to the headphone jack on the Picade hat.
My guess is that the issue has something to do with the Picade hat and sound drivers in Buster.
My model is a blue one and connects via USB.

Did anyone here face the same no sound issue, and by chance found a fix for upgrading these early Picade versions to the latest Raspbian Buster based RetroPie?


Hey! I encountered this problem with Pi 4 B and to solve it, go to terminal and type in sudo raspi-config . Then go to 1 and go to audio settings and make sure headphone port is selected, then do ok, then exit raspi-config, back in terminal do sudo shutdown -h now, then plug in speakers or headphones to the headphone port and reboot it up. It should work now.

I have never had a picade but as it is running on Raspbian it should work!

Hope this helps!

Alex :)

The Pi Foundation just recently switched to PulseAudio, I’m thinking that “may” be what messed things up for you. I don’t have an answer but I’m guessing you may need to change a setting in that someplace.
Another option is to go back to an older version of Raspbian, the one that worked before.
You can get older versions here.
Index of /raspbian/images (

@alphanumeric Yes - I had to switch to pulseaudio
BUT you may need to switch to headphone output in raspiconfig

@FutureGaming1 does that get you sound from the Picade Hat Jack or the Pi’s audio jack?

@alphanumeric Pi Audio jack - I have a pi 4 B

Ok, thanks for that info. I do believe the Picade Hat drives a speaker, and that might be what the OP wants to get working again. That’s why I asked.

Thank you alphanumeric and FutureGaming1 for your suggestions and support.
Maybe, let me precise a little bit my findings so far.

To make sure that sound will output in my Raspberry Pi 2, here is what I did, all in a console session.

  1. Added a few lines in the config.txt file (to minimize the headphones dither and to make sure that the hdmi required for the display is launched early at boot time)
    sudo nano /boot/config.txt

  2. Replaced .asoundrc content
    nano /home/pi/.asoundrc
    defaults.pcm.card 1
    defaults.ctl.card 1
    sudo reboot
    → This makes sure that the headphone will be the default sound output device.

  3. Check that headphone is the default device, and that I can manage volume
    → Success.

  4. Check that sound outputs correctly with a speaker directly connected to the headphone
    omxplayer -o local /home/pi/RetroPie/roms/indo.mp3
    omxplayer -o alsa /home/pi/RetroPie/roms/indo.mp3
    → Both local (headphones) and alsa (alsa driver) output the mp3 file in the speaker, success.

  5. Plug back the jack plug to the Picade blue hat
    omxplayer -o local /home/pi/RetroPie/roms/indo.mp3
    omxplayer -o alsa /home/pi/RetroPie/roms/indo.mp3
    → Music plays with both commands, and sound outputs correctly through the Picade speakers, success.
    So, the Picade hat seems to work correctly, as expected.

  6. Now, back to RetroPie and its user interface, whatever options I seem to select for sound options, no sound at all, failure!
    → Maybe everything is more of a RetroPie issue after all!


I don’t own a Picade, or game on my Pi, JFYI. I can’t offer much I’m afraid. =(

5 test. I added another test in the console:
aplay /usr/share/sounds/alsa/Front_Center.wav
→ this played just fine.

Then… I don’t really know why but:

6 fixed. Now, back to RetroPie and its audio settings screen, here are the options which just worked for my setup:

This fix and settings might help other people in upgrading these early Picade/RPi2 (or 3) versions to the latest Raspbian Buster based RetroPie.


@aldweb Glad you fixed it. On your solution post did you use raspi-config?

Alex! :)

I had used raspi-config earlier, with no success.
This is why I took a different under the hood path.
This was my step 2, replacing the .asoundrc file content with:
defaults.pcm.card 1
defaults.ctl.card 1
I guess this is the one trick which solved all of my issues.


Hi @aldweb again - Glad you fixed it and your picade is up and working!