Pas de son picade X hat

Hello,
I cannot get sound with the Picade X Hat card, the connected speaker does not give sound. I tried with the jack port of the raspberry pi 4 and it’s ok but very weak. I can’t find the information. I installed the drivers: “curl -sS https://get.pimoroni.com/picadehat | bash” and nothing … under retropie nothing … I despair. Can you help me ? thank you.

Hi,
A few more details would help…
What image are you using on your sd card? Is it RetroPie, or a pre-installed card?
Does everything else work - arcade buttons, joystick, etc?
My experience with the sound on my Pi3 was that when I installed the X HAT driver, the jack port sound output was disabled. It’s odd that you still get sound from the jack port.

Hello Mironc,

Thank you for your help. Indeed the sound always comes out of the Jack …
I installed Retropie via the procedure below on a 16 GB microSD. In addition, I installed the Picade drivers several times and the answer is still “already installed”.


At the root of the boot partition, I found a file named “config.txt.picade-preinstall.txt”, copied it and renamed it to “config.txt”. After restarting, still no sound.

In emulstation, what parameters should you choose: audio card? audio device? OMX player?

I do not know what to do…

See you soon.

Hello again,

Following various tests, I have sound on the games but the volume is at the maximum. with certain games I can adjust it, but older games don’t have the option. Also I don’t have music on the GUI.
I also have massage when I put myself on the command line “Alsa lib controle.c: (snd_ctrl_open_noupdate) Invalid CTL dmix, lv10: VolumeControl :: init () - Failed to attach to default card!”
What should I do ?
Thank you all for your help.

The file “config.txt.picade-preinstall.txt” in the boot folder is a copy of the config.txt file that the xhat installer makes before it changes the file. If you’ve copied this file back to config.txt, you need to reverse that change.

In Emulation Station my sound settings are…
Audio card: DEFAULT
Audio Device: PCM

The sound problems and the error message on the command line are probably related. You could install the xhat driver using the manual method to see if it gives you any error messages. Do this from the command line as follows:

git clone https://github.com/pimoroni/picade-hat
cd picade-hat
sudo ./install.sh