Problem with Sound on Picade X hat


I installed Retropie and it works fine, I can adjust the sound and the games have sound.
Once I tested it, I added the Picade X hat and installed it with the following command,
curl | bash
The joystick and buttons works without problems but there is no sound.

I get a “lvl0: VolumeControl::init() - Failed to find mixer elements!” error when starting a game.
I tried the Raspi-Config and Audio setting and it tells me “No internal audio devices found.”.

I would like to play the sound through HDMI and saw a note about a script that would force HDMI output so I tried the following,
curl | bash
And selected option 3.
There is still no sound and no internal audio devices found.

I don’t need the sound output on the Picade X Hat so is there a way to disable it and get the HDMI sound output?

Picade X USB-C.
Raspberry Pi 3 Model B.
RetroPie 4.7.11
Linux 5.10.17-v7+ armv7l GNU/Linux

/Fredrik S.

I found the following posting after some more searching,

This fixed the sound issue and Retropie is working again.

/Fredrik S.

One thing that “may” be messing things up is that the Pi Foundation just recently switched to using Pulse Audio for sound etc in PiOS.
The other thing to keep in mind is that the Picade X Hat installer switches sound to its onboard DAC which uses the attached speaker. It switches the sound to i2s, away from the onboard or HDMI.