Picade Console No Sound with Raspberry Pi 4


I just bought the Picade Console at MicroCenter, installed the latest retropie build and xhat software. However, I get no sound from the speaker. If I go to Sound Settings in Emulation Station, Volume always goes to Zero no matter what setting I try. If I go to Raspi-Config, it says “no internal audio devices found”. I have read other posts but I don’t see a fix for this. I just want the speaker provided as part of the Picade to work. Does anyone have a fix?

Have you tried this? (I found it here: Picade Console Assembly instructions


Once you’ve installed the software, the volume of the speaker will be set at 100% by default. If that’s a bit much, you can adjust the volume using the sound settings menu, which is accessible from the Retropie menu by pressing whatever button you’ve got mapped as START. Your ‘audio device’ should be set to PCM , ‘audio card’ to DEFAULT and ‘OMX Player Audio Device’ to ALSA .

Like the key mappings, these volume settings will only apply to the emulators that inherit their settings from Retropie, so you might find that you need to adjust the volume for some emulators from within their own settings.

Thank you but, these settings do not work. Raspberry Pi no longer uses ALSA. They use PulseAudio. That is why when I run Raspi-Config from Emulation Station, its says, "no internal audio devices found”. The PiCade Hat looks like it is set up for ALSA so, no sound.

Did you install a RetroPie image, or did you install RetroPie on top an existing OS installation?

On my system installed using a RetroPie v4.7.1 image, it’s using ALSA.

I installed the RetroPie Image, RetroPie v4.7.1. However, if I check Raspi-Config, System Options, Audio, it says No Internal Audio Devices Found.

I am also getting these two messages when going into Raspi-Config:

VolumeControl::init() - Failed to attach to default card!
AudioManager Error - Unable to open SDL audio: ALSA: Can’t open audio device: no such file or directory

I also get No Internal Audio Devices Found when I go to Raspi-Config, System Options, Audio. I guess this is looking for the Pi’s onboard audio, which I think is disabled by the XHAT install.

I don’t get the volume and audio manager errors when I go into Raspi-Config.

Can you go to a command line and run the command: aplay -l (lower case L).
This is what I get:

**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 [HifiBerry DAC HiFi pcm5102a-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

What options do you get in the OMX Player Audio Device setting in Emulation Station’s Sound Settings menu? Mine is set to BOTH, but there are three ALSA options as well.

I have the same as you. I have tried all of them with no success.
I also noticed that ALSAUTILS is installed but it can’t find ALSAMIXER and if I try to install ALSAMIXER it will not install (from the console). So confused…

Have you done a system update via the RetroPie screen > RetroPie Setup > Update

Sorry I missed the aplay command above. I ran it and got the same listing you show above. I also ran the system update via RetroPie and rebooted but still the same issue.

Did the XHAT software install OK? It might be worth installing it again just in case.

Yes, I reinstalled it but nothing has changed.