No sound on picade


#1

Hello team.

I mounted the picade, I installed the retropie, but the sound does not work. Does it have to be modified or was it to work? In case of any modification, please explain. I do not know how to handle the retropie very well. thank you!


#2

I think the default for retropie is to send the sound via the HDMI connection - usually fine but the Picade screen doesn’t have built-in speakers.

In the stock Picade the speakers are connected to the 3.5mm jack on the Pi.

It’s a simple fix, In retropie just go to settings and change the audio settings from HDMI to 3.5mm output. That should fix it.


#3

thanks for answering! I already made that change and it did not help. Still not working. Is there another setting I can change?


#4

Sorry, that was all I had to do on mine.

If you plug some earphones directly into the pi sound port, do you get any sound when playing a game?


#5

I’m having the same issue. I get very quiet sound if I plug in headphones, but the speakers are a no go. Additionally the volume buttons on the side do not increase or decrease the volume on the headset. I actually figure this is working normally as they are likely buttons that need to be configured to the volume controls in Retropie. However, when pushing these 2 buttons the light on the PCB does not light up like with all other buttons.

I have tried specifying the 3.5 jack but this has not solved the issue. Please help :(


#6

Nevermind. I don’t know what changed but today the sound just works and so do the volume buttons.

On a separate note: If anyone can tell me how to get the Pie to recognize my keyboard as a keyboard and not as a controller I would GREATLY appreciate it. Right now I can’t push ‘tab’ to access the MAME menu so my controls are just a mess. Any help would be awesome! Thanks!


#7

I had same problem with MAME. In then end I gave up trying to find a solution on the web, and just reinstalled Retropie fresh.
All then worked fine. Not sure what the issue was, maybe some config item I played with.


#8

Even more strange is that in 1 game (asteroids) the ‘tab’ button does pull up the MAME menu. Bizarre! Unfortunately I really need to configure some individual games such as Mortal Kombat. Oh well. I think I’ve spent enough time trying to figure it out. Time to just enjoy the 90% that works fine.


#9

Does sound very much like the issue I had, I couldn’t use the tab button on the keyboard to bring up the name menu.
After a clean format of the disk, making sure I used format with erase all data option, I reinstalled Retropie. Now everything works as it should. Keyboard name control button works in all games. I’m wondering if it was because when I first installed retropie I had issues with the screen, maybe i didn’t erase all the data during format, and then had overlapping files.
Definately it works well now.
Worth a try, and only took me 10 mins, compared with the 3-4 hours playing about with various settings