Picade HAT (original) speakers not outputting sound


#1

I’ve got a Raspberry Pi 3 B + attached to a Picade HAT (original, not X HAT).

Everything is working now except for the audio. When I plug my heaphones into the RPI the sound works, however the wired speakers for the PIcade do not work at all.

They worked one time when I tested out my system but have not worked since.

I tried switching the + - wires, still nothing. There is no option in Raspi-config for speaker audio (I only see auto, HMDI and headphone back). Honestly at my wit’s end with this, it’s probably a faulty speaker but I want to see if there is anything else I can do prior to chucking it in the bin.

Could you please advise?


#2

Hi Cjb,

Please could you post the contents of your /boot/config.txt file? We need to make sure i2s audio is enabled, as that’s what sends the sound through to the HAT. Sounds like you may have it set to go out of the Pi’s headphone jack, I’m not sure if that and i2s can work together or if it’s an either/or scenario but we’ll be able to tell more from what’s in the config file.


#3

I’ve already hooked my system to the table before you responded and given up on this, thanks anyway.


#4

Just for curiosity though. I can remove the SD anytime, here are the contents.

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

hdmi_drive=2
hdmi_force_hot-plug=1
hdmi_force_edid_audio=1

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
#overscan_scale=1
hdmi_force_hotplug=1 disable_splash=1 dtoverlay=pwm-2chan,pin=18,func=2,pin2=13,func2=4 #Enable audio (loads snd_bcm2835)
#dtparam=audio=on
dtoverlay=i2s-mmap
dtoverlay=hifiberry-dac
dtoverlay=picade
dtparam=audio=off


#5

Looks like a lost cause here. I’m gonna go for a USB powered speaker.

Would I be able to return the defective part for a refund or is it too late? I bought it in July.