New Picade joystick doesnt work!


#1

Hi Guys

Built my new Picade today it was a long process but was happy when it was finished!
The main issue is that the Retropie doesnt detect the joystick or any of the buttons I just seem to be getting “no gamepads deteced”

I have retraced my steps and it doesnt seem like there is anything wrong I also SSH’d to the Pi and installed the HAT software and I get the LED light on the back of the PCB.

It detects a normal usb xbox controller I have so I at least no that the USB ports are working.

Can anyone suggest anything that I can try? Im at my wits end! Someone said previously about flashing the software on the PCB to resolve issues with the joystick in the past?

I have also attached a screenshot of the lsusb report.

Many thanks in advance
Glen.


#2

Bump Bump Bump Bump Bump Bump please reply


#3

Try reversing the connector for the joystick, I had a problem with mine that it only recognised “up”. This was resolved by reversing the connector, apparently they made a mistake on the instructions, I’ve read this in comments elsewhere on the forum


#4

Did having the joystick connector the wrong way stop all operation of the joystick like no detection at all on startup or just the “up” direction through? I think I have already tried this

Is anyone from support actually on here?


#5

Just to be sure: You did try to configure the joystick in RetroPie (by holding a button/direction)?

It will show “no gamepad detected” because the joystick emulates buttons, not a joystick. This was confusing me in the beginning as well


#6

Tried this every direction and buttons made no difference still doesnt detected anything!!! :(


#7

In one of the first steps when setting up the picade after you installed retropie it asks you to install the drivers from GitHub. My joystick and buttons didn’t work either at the beginning. I rewired everything again but it wasn’t until I download the drivers for the picade hat did everything start working.