New Picade joystick not responding


#1

Hi all
Assembled the new picade and mostly it works fine, eventually managed to start up retropie, connected a 2nd keyboard for configuration, but when I go to the input menu, it only recognises keypresses from buttons, not the joystick. I reinstalled the software, rebooted again, and same problem.
If I run the “showkey” commands there is nothing. I checked that the connection to the picade X hat isn’t the wrong way around, but it doesn’t matter which way it is plugged in, there is still no response. Any ideas?


#2

What happens if you drop in to Terminal, run “watch -n 0.1 gpio readall”, and waggle the joystick? Do you see any activity on the GPIO at all?

Are there any visible flaws with your joystick ribbon cable or connection header on either end?


#3

Thanks Phil - I went back and checked all of the wiring - there is a slight “bend” on the joystick connector that makes it loose unless pushed firmly back, I did this, and lo and behold, I get keyboard 103-106 on trying again.
Thanks for the quick reply.


#4

Brilliant! Glad you found it. Happy gaming!


#5

Thank you!
Its all working well now