Picade X-Hat - joystick not detected though buttons do

I have a Picade X-Hat connected to Raspberry Pi 4B, in a self built arcade machine.
I followed the instructions in Assembling your 8" or 10" Picade with PICO-8 and and ran the Picade Hat installer.In the Retropie welcome screen, all the connected buttons are detected when pressed and I can map them. However, none of joystick movements are detected. My joystick is connected to the five joystick pins of course. Tough I’m quite sure I can tell where the joystick ground is, I also tried the opposite end wire as ground. Furthermore, I tried to connect the joystick (one directional wire and the ground wire) as a button, but it was also not detected (was it supposed to be detected while connected as a button??).
I would highly appreciate any help.

They both work in the same way - pressing a button or moving the joystick in one direction completes the circuit. If you correctly connected a joystick direction to a button connector on the XHAT it should be detected by the RetroPie controller config wizard.

To check if the joystick is working you can quit Emulation Station and see if it has any effect on the command line. The four joystick directions emulate the four arrow keys on the keyboard, so if you press some of the arcade buttons to get some text on the command line, the joystick left and right should move the cursor left and right.

You can physically check the joystick if you have a continuity tester. Test between the ground pin and one of the direction pins - when you move the joystick in the relevant direction the circuit should be completed.

Thank you very much for your help. I followed your advise to monitor the effect in command line, connected the joystick instead of a functioning button, and was able to trace the issue - simply bad wires.
All is working now. Thanks!