New Picade joystick only registering Up movement


#1

I’ve really enjoyed putting together my new Picade, and everything was going smoothly (relatively, at least; this is a bit out of my technical comfort zone) until EmulationStation booted up with the initial input configuration. It registered Up, but no other direction on the joystick.

If I spin the joystick around randomly, it will occasionally pick up Down and Right, but I’ve never had it register Left yet. I’ve been browsing the forums to see if any problems or solutions might apply to my situation, and here’s what I’ve tried, to no avail so far:

–Checked the connection of the joystick and corresponding PicadeHat inputs. This to me is the most likely suspect, and I will be checking it more thoroughly if nothing else does the trick. I did seem to get a tighter/straighter connection on the joystick, but it didn’t fix the issue.

–Reran the PicadeHat script to make sure it was installed properly. Everything appears to have run without issue. Should the console joystick and buttons be registering as a keyboard at the ES input configuration? That’s what it showed for me. It still has a lot more input options than there are buttons on the Picade, so I want to make sure there isn’t a step I skipped.

–Ran the GPIO script suggested in a couple other threads. It registered every button press, and always when I pushed Up on the joystick. It also reliably registered the Up-Left and Up-Right diagonals, but no other joystick inputs.

Based on that information, does anyone have any recommendations of what I might try, or a step I might have overlooked during the build? Like I said, I’m going to take a closer look at the joystick connections to make sure everything is in its right place, but am hoping to not have to remove the console. (Those last nuts and bolts were tricky to reach!)

Thanks in advance for any advice you have, and let me know if there’s any potentially helpful information I left out.


#2

Its possible that your connector on the Picade X Hat is the wrong way around? In other words only one pin is being grounded so you only get a single connector instead of all 4.


#3

That did it, thanks! I thought I had followed the diagram on the instructions, but I must have flipped it. All is well now. :D


#4

You did follow the diagram instructions correctly - unfortunately the diagram is wrong :-(

I had the same problem


#5

Well, that’s unfortunate. I ran into a few bumps along the way: this, the missing instruction to uncomment hdmi_force_hotplug=1 from the config.txt, and one of my speaker wires being disconnected (woo bonus soldering practice!). But thanks to this community, I’ve been able to get through it all, and I’ve got it up and running to the point where any other changes I make are just minor tweaks and personal preferences.


Weird Problems with Picade Joystick