First Build: Buttons fine, Joystick not working

#1

Hey all,

Just got my first Picade (2018, 8”), and it’s been a blast to build, and the kit is very well designed and engineered.

While everything else is working well, when I go to set up the controls, the buttons work but the joystick does not. What’s strange is that 2 of the diagonal clicks register, but none of the straight (up/down/l/r) switches register in emulationstation.

I have:

  • triple checked that the wiring is correct:
    — made sure that the easy connector is fully in
    — made sure the ground is on the correct pin end on the Hat
  • re-installed the picadehat drivers
  • tried running a diagnostic tool mentioned somewhere in another post, but there were several 0s and 1s turning off/on, and the buttons didn’t seem to have any bearing in the tool.
  • examined the ribbon cable for kinks or cuts, looks ok

Again, buttons work. Is it possible that I just have a bad Joystick or joystick ribbon cable? Any other ideas?

Thanks!

  • Ira
#2

“… 2 of the diagonal clicks register…”. As far as I’m aware, the joystick only has up/down/left/right switches, no diagonals.

When the picade software is installed, the joystick produces the same key presses as the the up/down/left/right arrows on a keyboard. An easy way to see if it’s working is to quit Emulation Station (Menu > Quit > Quit Emulation Station) so you get a command prompt. Connect a keyboard, press a few keys, then see if the joystick left & right will move the cursor left & right. To test up & down, enter a few commands, then see if the joystick up/down will recall and step through the commands you entered.

#3

Heya, thanks for the response!

For all of these joysticks, the diagonal simply means that it registers the two regular directional’s switches at the same time (eg; UP+LEFT, etc).

I’ve built several full size cabs, so simply tried replacing the Picade joystick and cable, and the new one worked without any configuration. Put back the original Picade one, and nothing. It was a faulty ribbon cable or the pins in the joystick connector.

The joy is wearing off, and I’ve realized that the Picade seems to be extremely fragile, or only meant for one build:

  • the power button clips broke off when first connecting the wires (had to solder the wires on)
  • the joystick was faulty
  • BOTH audio wire clip (“locks”) broke off when reinstalling the wires for the second time
  • the official artwork templates have the display area is upside down (thin / thicker areas swapped for top & base)

Anyhoo, working now, using fixed/replacement parts.

Cheers/