Picade Joystick and buttons not working


#1

Hi There,

I ordered the Picade kit from the Pimoroni shop and built it without much problems following the video instructions. I installed RetroPie and after changing the boot.txt to get video out working the next step would be the configuration of the controls. I push and hold a button and a keyboard shows up to be configured. The d-pad up went fine as “KEY E”, next the d-pad down which says “Already taken”. All other joystick positions react te same way. They all try to register as “E KEY”.
Moving the joystick in terminal also gives “e” keystrokes for all positions. The same goes for the buttons except the control buttons. They transmit, esc, enter, c and e. tx light blinks on the pcb with every button and joystick movement.

I checked al the cables from the joystick and buttons to the pcb. I tried a different USB cable. I tried a different pi. I also tried updating the pcb firmware without any change. The update seems to run fine, so I think the usb connection is working properly.
Am I missing a configuration step or is the pcb faulty?

Regards,
Arjen


#2

After having had contact with support the problem was fixed by flashing the software to the pcb.
So it’s time to start modding and playing :)