No Gamepads Detected


#1

Yes I’ve already searched other topics but still can’t get this working, I ran the gpio readall and the joystick and all buttons are being recognised but still emulation station cannot see them no matter how times I press them. Yes I’ve already installed xhat but still nothing.
Anybody have any tips, it’s starting to give me a headache.


#2

Have you downloaded the latest version of RetroPie, or is this an old build you’re updating?


#3

It’s the latest 4.4, just in case there was a beta released since then I tried to update it but was told it was the latest version but I did let it update raspbian with no success.


#4

Can you check /boot/overlays for a picade.dtbo file and /boot/config.txt for a dtoverlay=picade entry?


#5

Checked and they’re not there.


#6

Hm- can you run the installer again?

curl get.pimoroni.com/picadehat | bash

… and let me know if you see anything untoward in the output- any errors, etc.


#7

When I reinstall -----

Checking environment
Updating apt indices

Checking hardware requirements

Checking for packages required for GPIO control
raspi-gpio is already installed

Checking for dependencies
alsa-utils is already installed
lsb-release is already installed

Github repo already present. Updating
fatal: index file smaller than expected

Finalising Install


#8

Good news, I formatted the sd card and reinstalled retropie, with still no luck but when I checked the sd card for picade.dtbo and the dtoverlay=picade entry they were both there. As I said it still wasn’t recognising the controls but looking at the config this was appended to the end -
hdmi_force_hotplug=1dtoverlay=picadedtparam=audio=off
by pressing enter between the statements before saving the controls are now being recognised hooray! Don’t know why the audio is being turned off if there’s no sound when playing I’ll edit that out.
Thanks for the help gadgetoid


#9

The dtparam=audio=off turns off the internal audio, since the picade dtoverlay sets up i2s audio to the connected speaker.

There’s actually no reason why they can’t coexist peacefully, but we turn off built-in audio in our installer because it’s the simplest, quickest way to get audio out of the right place with minimal confusion.

I’m a little surprised the config.txt ended up so broken- I’ll have to investigate that!